(CD) device not ready

March 8, 2005 at 15:07:45
Specs: Win98 SE, AMD 1,4 Gig

Hi Folks,
I got a similar problem as was posted last January.
When I try to access either my combo CD writer/DVD reader or my CD writer (both IDE) in Windows explorer, a message like 'Device is not ready' comes up. Both drives can read a CD in DOS. I can use both to burn in Nero v6 - this strengthens my belief that nothing is wrong on the hardware site. It must have something to do with Windows. Aspicheck seems to be OK. I also have Win on CD as alternative burning software.Tia!

See More: (CD) device not ready

Report •


#1
March 8, 2005 at 15:13:23

What kind of cd is in the drives when you attempt to access them?

Report •

#2
March 8, 2005 at 15:18:07

"Aspicheck seems to be OK". Please explain why you made that statement. What version of ASPI layer drivers are running?

Report •

#3
March 8, 2005 at 16:47:27

What was the fix last time and did you do anything just before this happened?

Derek.W


Report •

Related Solutions

#4
March 10, 2005 at 14:10:23

1) Whatever CD I put in, access is refused.
Most of the time I test with a CD that comes with a magazine or with another CD that proved to be OK.
2) I began to try and change aspi drivers, since I noticed Acronis had changed some of these files - at least I believe.
3) The last thing that happened before things went wrong was, I believe, installing Acronis True Image v.8 (... to make a backup of my system...)

I now have these files on my system:
W98\SYSTEM\IOSUBSYS\APIX.VXD (23KB,10/09/1999,13:06)
W98\SYSTEM\WINASPI.DLL
(6KB,10/09/1999,13:06)
W98\SYSTEM\WNASPI32.DLL
(6KB,10/09/1999,13:06)
W98\SYSTEM\ASPIENUM.VXD
(8KB,10/09/1999,13:06)
When I run aspi_chk.exe v. "1.00 (006)", a 113 KB program date 21-10-2004 (this is
probably the date of unzipping), from Adaptec, I read:
"ASPI is properly installed and is fully operational.
A total of 4 host adapters is found."
This aspi_chk.exe program is for Win95.
It refers to the four files as being version 4.60 (1021).

When I run aspichk.exe v. "2,0,0,0 (006)", a program dated 11-12-2001, I see
"ASPI is properly installed and fully operational" is greyed,
and only APIX.VXD and WNASPI32.DLL are referred to,
not WINASPI.DLL nor to ASPIENUM.DLL
Again the same version of thes 2 files is mentioned as 4.60.
While gathering information I had a look at
http://www.ncf.carleton.ca/~aa571/aspi.htm
but I haven't found the right solution yet.
What is strange, is that Nero (and probably WinOnCD also) do work.
Apparantly they use their own dll's?
Does it matter that both drives have target-id 1 and LUN 0?
Tia.


Report •

#5
March 10, 2005 at 14:54:55

Look at the article here on ASPI layer drivers. http://aspi.radified.com/
You may need to use the file "kill ASPI and reinstall. Read the article and follow all the links.

Report •

#6
March 11, 2005 at 12:54:23

Thx! I'm gonna have a look.

Report •

#7
March 11, 2005 at 14:07:43

Hello Folks,
I thought I'd seen 5replies to my message. And now I only see the first 3 responses.
Anyhow, went to http://aspi.radified.com and downloaded forceaspi.
I've run dumpaspi and instaspi, but to no success.
Still no access to the drives.
No difference either as for what aspichk is concerned.
I still hope to find an answer.
Theo - OThe Sea

Report •

#8
March 11, 2005 at 16:55:42

Download and run 274370USA8.EXE from here:

http://autourdupc.com/Logiciel/WIN98/Softs/98ETSE/

Reboot. Then download and run 243450USA8.EXE from here:

http://support.microsoft.com/kb/q243450/

Reboot.

You can also remove the cd devices in device manager and reboot to let windows set them up again.



Report •

#9
March 13, 2005 at 14:30:35

I'm sorry I could not reply earlier. Lost my password and now am logging in as Theo2001.
I will try your suggestion.
I removed my drives (combo + DVDwriter) before, that is in device manager.
At restart the devices were added "automatically" by windows.
I'm curious about the files you mentioned and will let you know as soon as possible.
Thx


Report •

#10
March 13, 2005 at 16:43:17

The first updates cdvsd.vxd, one of the files windows uses for cd devices. The second updates esdi_506.pdr, one of the IDE disk drivers. The microsoft page says it's for a specific fix but even if you don't need it, the update won't hurt.

Report •

#11
March 14, 2005 at 12:56:42

Great, great, great ...
Many thanks for Dave's tips: I installed 274370.exe and for the first time since last october I can see what is in the drives.
So I own you a pint (or 2, one for each drive?)
Would you still advice me to install 243450.exe?
As far as I can see, I don't have a problem with my 40 Gig and 120Gig HD's?
TIA!

Report •

#12
March 14, 2005 at 13:33:56

Thanks for posting back your results. If everything seems OK you probably don't need to run the second update.

There's another update Q273017 that you might keep in mind. You probably don't need to install it either unless you experience the problems it describes.


Report •

#13
April 19, 2005 at 15:10:37

I have a similar problem, which started suddenly about five days ago. One CD-Rom Drive, one CD burner. System 98SE, 700MHz Athlon. Lots of HD space. All has worked fine for several years.

Now, neither drive plays Audio CDs through NTI CD Maker, nor through Creative Playcenter2. Can't import audio CD into Magix Audio Cleaning Lab. Both drives will play MP3 from CDs in the same drives. Playcenter hangs up looking for audio CD. Magix says "ASPI not ready." NTI says "No supported CD-R or CD-RW Drive Detected."

MS "CD Player" works, plays audio CD. Creative diagnostic test panel plays CD Audio OK.

The drives show up in File Explorer. Everything shows OK in System Device Manager.

Reinstalled NTI and Creative Sound Blaster software, no help.

Next step may be to reinstall Win 98SE.

Any ideas, please?

Thanks,

Steve


Report •


Ask Question