Win7 Homegroup network access denied problem

December 31, 2009 at 14:00:23
Specs: Windows 7, i7 920/6GB
I had my 2 Win7 computers networked using
Homegroup. I was using a 2nd HDD on my
secondary computer as a backup location for
my first. All of the sudden, I am unable to
access the HDDs on the secondary computer.
When I go into Sharing, the HDDs are set to allow
sharing for both Read/Write functionality. But
when I go to my primary PC and attempt to
access either HDD on the secondary, I get
this error: "Windows cannot access \\BEX-
PC\Bex - C
You do not have permission to access \\BEX-
PC\Bex - C. Contact your network
administrator to request access."
In an attempt to get it working again, I have left
the homegroup on both PCs (essentially deleting the homegroup,) and completely
recreated a new homegroup, adding back the
permissions on all the HDDs and folders that I
want access to. I still have the same issue
though. I can access everything on my
primary PC from my secondary, but get the
error when trying to access the secondary
form the primary. I am at a loss. Any
suggestions?

See More: Win7 Homegroup network access denied problem

Report •


#1
January 2, 2010 at 21:19:00
I am still having some issues with Windows 7 home networking (though win7 to xp in my case is more one way than the other) so I might not be the best to answer this question, But here is at least one suggestion while you are waiting for a more complete one:
Try looking in windows firewall and making sure that the networking wiz added the proper permissions both ways. If you see a permission on one that is not on the other, or a slight difference, try creating the equivilent on the other. ((also scan both for nasties that might be causing problems)) Post back anything unusual and that might give someone else an additional clue.

Report •

#2
January 2, 2010 at 22:48:32
No viruses, spyware, etc. Both are new installs. I tried
completely turning off the firewall, and I still get the same error.
Both PCs are set up exactly the same way, so it makes no
sense that one allows access and the other does not. Thanks
for the suggestions!

Report •

#3
January 3, 2010 at 18:54:02
Are you connecting with a direct cable, through a hub/switch, or through a LAN router or a wireless router? Have you thought of trying different network cables or exchanging cables? (Direct connect requires a crossover cable I believe rather than a patch cable. a bad cable could be a problem. check router settings.
Otherwise I think you did everything in windows I can think of...

Report •

Related Solutions

#4
January 3, 2010 at 19:15:02

Report •

#5
January 3, 2010 at 20:54:14
I am connected through a wireless router (D-Link DIR-628).
Since I have access one way, but not the other, I wouldn't think it
was the router. Also, my Homegroup was working fine both
ways for a few days and then just stopped. I hadn't made any
changes to the router settings or any in Windows for that matter.
I went through the guide above (OtheHill) but didn't see anything
in it that I haven't done/tried. I really appreciate the help. I just
don't know what else to try. Thanks, and if anyone has any
more suggestions, I'd appreciate any you have to offer.

Report •

#6
January 4, 2010 at 03:05:08
Check the workgroup name. I have had problems with the workgroup name in other versions of Windows in the past.

Each version uses a different default name. I am not sure what the default name is because I am not using it. I only have one Windows 7 computer running out of 5.

I would guess something in the shares setup is off. Check who can share, for instance.


Report •

#7
January 4, 2010 at 09:22:52
On both PCs the workgroup name is WORKGROUP. Both PCs
are setup to allow Full Control for Everyone (Full Control, Change
& Read are all checked for everyone.) I only have one user
account on each PC (administrator.) Is there anywhere else I
should look? Thanks again.

Report •

#8
January 4, 2010 at 10:06:42
I don't know if this is related to you problem but I have a home network with 5 computers. Three run 24/7. One is Windows 7 ultimate. The other two 24/7 units are WinXP home.

I have had to reset my router a few times due to the same issue you have. I don't know why things should be any different when using Windows 7 but I didn't have that problem when I was running WinXP on all 3.

ATry going to control panel> Network and sharing center> Troubleshoot problems.

Or just try setting up a home network on the same screen.

Because I only have ONE Windows 7 machine I didn't bother to investigate the advantages, if any, of using HomeGroup.


Report •

#9
January 4, 2010 at 13:20:50
I re-ran all the troubleshooters and didn't find any issues, but was
finally able to get newly shared folders from the 2nd PC to be accessible by the 1st PC. Not sure what the issue was. I do,
however have another question, if anyone knows the answer. I
am able to access entire HDDs on my 1st PC from my 2nd, but
am unable to access entire HDDs on my 2nd from my first. I still
get the same error. Any ideas?

Report •

#10
January 4, 2010 at 19:46:58
Did you right click on the drive in 'computer' (formerly 'my computer') go to share with and select advanced sharing, and select options to share the entire drive, otherwise just select or create a few folders and make them share folders in the same way.

If homegroup gives you enough trouble, you might try the other option which allows you to join an existing home network and allows non-windows 7 machines and works similar to XP in that you just have to name the workgroup the same and select the options you like. It may have less security, but simplicity sometimes is more reliable.


Report •

#11
January 4, 2010 at 21:45:48
Yea, that's how I set all my HDDs up. I may end up going the
old home network route though. Thanks for the help!

Report •


Ask Question