Articles

older CD win 95 will not run. says it needs QuickTime 2.1.2.

November 30, 2012 at 09:12:59
Specs: Windows 7, pro86x86 10gigs

I have cd to install,older than ver 7, it will not install because I need version of quicktime 2.1.2.
how do i manage this? the cd is Puzz3D....win95. I installed the program but it will not run

See More: older CD win 95 will not run. says it needs QuickTime 2.1.2.

Report •


#1
November 30, 2012 at 09:29:42

Right click on the game's executable file, click Properties, then run the game in Win95 compatibility mode.

Report •

#2
November 30, 2012 at 09:49:18

Older versions of Quicktime, try one of these if riider's suggestion doesn't work. I'm not sure if they will run on Win7, you may need to run this in compatability mode as well

http://www.oldapps.com/quicktime_pl...

http://www.oldversion.com/QuickTime...



Report •

#3
November 30, 2012 at 09:59:00

QT 212 direct link is also at oldversion. if that's what you want:

http://www.oldversion.com/download-...

Always pop back and let us know the outcome - thanks


Report •

Related Solutions

#4
November 30, 2012 at 12:24:35

I kind of doubt the game will install under Windows 7 without using a compatibility mode.

Win95 did not use a program folder like the newer versions of Windows. Everything was installed to the root directory. Windows 7 will not allow that to happen.


Report •

#5
November 30, 2012 at 12:35:47

#4 kinda surprised me, although it was a long time ago....

This seems to suggest that there was a programs files folder:
http://www.computerhope.com/w95sof.htm

Just how much it was used might be a different matter - perhaps just for accessories.

Always pop back and let us know the outcome - thanks


Report •


Ask Question