LG DVD Drive not recognized after W7 upgrade

Lg / Hl-dt-st dvd-ram gh22lp20...
July 24, 2010 at 04:31:29
Specs: Windows 7 64 Bit, 6GB

After upgrading to Windows 7 64bit my DVD player/recorder stopped working so it was replaced with the above - Win 7 compatible. It does not appear under the Computer drives however Device Manager displays it with a yellow triangle. On investigation via properties the following is shown "A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)" The device has been uninstalled, system rebooted many times the drive works fine with other O/S's and the Bios recognises the drive - HELP please I am lost for ideas. Thank you in eager anticipation

SIW gave the following information if it helps

DVD/CD-ROM drives
HL-DT-ST DVD-RAM GH22LP20 ATA Device
Device ID IDE\CDROMHL-DT-ST_DVD-RAM_GH22LP20_______________2.00____\5&F2BD12B&0&0.0.0
Status 0x01802400 Has Problem
Problem 0x00000020 (32)
Service cdrom
Capabilities 0x00000000
Config Flags 0x00000000
Class CDROM
Manufacturer (Standard CD-ROM drives)
Hardware IDs IDE\CdRomHL-DT-ST_DVD-RAM_GH22LP20_______________2.00____
IDE\HL-DT-ST_DVD-RAM_GH22LP20_______________2.00____
IDE\CdRomHL-DT-ST_DVD-RAM_GH22LP20_______________
HL-DT-ST_DVD-RAM_GH22LP20_______________2.00____
GenCdRom
Compatible IDs GenCdRom
Class GUID {4d36e965-e325-11ce-bfc1-08002be10318}
Location Channel 0, Target 0, Lun 0
Enumerator name IDE
Description CD-ROM Drive
Friendly name HL-DT-ST DVD-RAM GH22LP20 ATA Device
Driver {4d36e965-e325-11ce-bfc1-08002be10318}\0001
Physical Object Name \Device\Ide\IdeDeviceP0T0L0-0
UI number 0x00000000
Install State 0x00000000
Device Address 0x00000000
Device Configuration File cdrom.inf
InfPath cdrom.inf
InfSection cdrom_install
ProviderName Microsoft
DriverDateData 00 80 8C A3 C5 94 C6 01
DriverDate 6-21-2006
DriverVersion 6.1.7600.16385
MatchingDeviceId gencdrom
DriverDesc CD-ROM Drive
Class CDROM
ClassDesc DVD/CD-ROM drives
IconPath %SystemRoot%\System32\imageres.dll,-30
Installer32 storprop.dll,DvdClassInstaller
EnumPropPages32 storprop.dll,DvdPropPageProvider
SilentInstall 1
NoInstallClass 1
LowerFilters PxHlpa64
UpperFilters GEARAspiWDM


See More: LG DVD Drive not recognized after W7 upgrade

Report •


#1
July 24, 2010 at 05:19:21

Did you check to see if your hardware is compatible with Windows 7 BEFORE installing it?

Look at the link below.

If that is not the issue then you may need to install drivers for your motherboard chip set. Get them from the board manufacturer's site, if any are available for Windows 7.

http://windows.microsoft.com/en-US/...


Report •

#2
July 24, 2010 at 05:48:24

Hi OtheHill,

Yes, according to the checker it was/is compatible,its a Dell Precision 690 workstation, I also checked the new LG drive, this states on the box that it is Windows 7 compatible, I also checked on the windows 7 list of compatible drives where it is also listed as compatible. I have also checked a Philips drive which has the same symptoms....


Report •

#3
July 24, 2010 at 06:38:53

Then you may need to install drivers from Dell.

Report •

Related Solutions

#4
July 24, 2010 at 06:49:36

Thanks for the help thus far, alas I am still without success, have updated BIOS, Chipset and various other drivers to Vista 64Bit as Dell don't specify Windows 7 64 Bit. The hunt goes on! I may have to contact Dell for help

Report •

#5
July 24, 2010 at 07:41:34

Try THIS and/or THIS.

CoolGuy


Report •

#6
July 24, 2010 at 07:52:48

Hi Coolguy

Many thanks for the suggestion but as the saying goes been there bought the t-shirt all withut success. Down to the last strands of hair.. after that teeth or finger nails I guess :-)


Report •

#7
July 24, 2010 at 08:29:00

If you have ghost DVD drives in your system, this weird behavior may result.

You have to clean your system of ghost DVD drives.

To this end, open a command prompt with admin privileges and give the following command:

set devmgr_show_nonpresent_devices=1

start devmgmt.msc

Device Manager will open. Go to Appearances tab and tick Show Hidden Devices.

Now expand DVD Drives. If you see greyed drives there, remove them and restart your PC.

You can do this to other ghost devices with Code 45. Many of the USB flash disks will show up there. Do not bother to clean them. Otherwise, drivers for them will install when you reconnect them.

Hope this helps.

CoolGuy


Report •

#8
July 24, 2010 at 08:45:41

Hi Coolguy, the help is appreciated, yes the hidden items were an eye opener so I did as suggested and deleted them and then restarted. Sorry to say other than cleaning the device manager it made no change - except I pulled out a bit more hair... nearly bald now! Wonder if MS sell wigs:-)

Report •

#9
July 24, 2010 at 08:57:12

Have you considered the possibility that you may have been infected with a rootkit or virus ?

CoolGuy


Report •

#10
July 24, 2010 at 09:22:34

Hi

I have Microsoft Security Essentials running and have looked at your suggestion but I can not see any indication of this being the cause as it is so specific but I could be wrong so I will continue with the investigation thanks.


Report •

#11
July 24, 2010 at 10:33:20

Have you tried removing the drive from within Device manager and then rebooting?

Do you have any third party burning software installed? Did you install any and then remove it? How about a scanner?

One of the links by cool guy was to remove the upper and lower filters. Did you try that?


Report •

#12
July 24, 2010 at 10:41:19

Look at the link below for thoughts on error 32.

http://social.technet.microsoft.com...

Try logging in as Administrator and use some of the above fixes.


Report •

#13
July 24, 2010 at 12:19:56

There appears to be a firmware update for your product here for Win 7 compatibility. You may try that. For this you must put the dvd drive in a machine where it is recognized properly.

CoolGuy


Report •

#14
July 24, 2010 at 12:20:39

Thanks again OtherHill

I am invesstigating.... I must have missed the Upper and Lower filters will investigate that too. Do you know how to remove them?


Report •

#15
July 24, 2010 at 12:22:46

Hi CoolGuy, Thanks for checking that I have checked the version shipped and it is 2.0 Do you think it's worth running the upgrade regardless?

Report •

#16
Report •

#17
July 24, 2010 at 12:59:35

OK Let's party.....

Get out the hair restorer and lets celebrate ...

Removing the Upper and Lower filter after deleting the devices and removing the hidden entries as suggested WORKED :-) :-) :-)

Thank you both SO much for the time you have spent with me today I am so incredibly grateful


Report •

#18
July 24, 2010 at 13:07:56

Glad you got it sorted out. Thanks for returning with the news. Many don't bother.

Report •

#19
July 24, 2010 at 13:12:09

That is both dissappointing and frustrating. I work designing software and databases as well as coding but always try to avoid these issues so I appreciate the help. If I can be of help then you can contact me via this I guess

Report •

#20
July 24, 2010 at 13:22:34

Many folks must feel it is their right to cull what they can from wherever, with no thought of where or why the information is there.

Your issue was a pleasant journey because you followed the prompts and provided feedback. Probably due to your profession.

I am not a fan of deleting the filter unless all else has failed. Microsoft must have them in place for a reason. They are actual a group of files and if one knew which one to delete could probably keep the remainder. Every so often this issue crops up. I really think it may be bad coding on the part of MSoft. These issues seem to come in batches, which leads me to believe updates may be the cause.

I do not have auto updater enabled. I wait a few days after MS has released updates to MAYBE download them. I NEVER use any hardware updates from them. If needed, get them from the manufacturer. If it ain't broke, don't fix it.

Well I have managed to ramble so I will sign of with a good computing.


Report •

#21
July 25, 2010 at 07:18:13

Although the moderator has changed the titl of this issue it is a generic solution as the problem was found with two other different maked of DVD/CD ROM - Philips lightscribe and Sony NEC Optiarc. So its worth a tryu as a possible fix for other combinations. Best of luck - remember it is we who make things impossible!

Report •


Ask Question