Articles

Catalyst control centre not working

November 18, 2009 at 17:10:38
Specs: Windows 7

I can no longer start catalyst control centre in my administrative account on win 7. It gives me the error: "catalyst control centre:host application has stopped working"
When I switch over to the Guest account, it works fine.

Also, my background image on my desktop will only show solid colors on my admin account; on my guest account that works fine too.
Note: the desktop background would function with no problems on my admin acc. for the first couple of days, then simply stopped and went to default black background that can only be changed to another solid color. Certain directories are also restricted to me for some reason, and they are simple ones like "my pictures" and "my music" etc..

Please help me this is driving me nuts..
I've done everything I could possibly think of, ie, uninstalling all ATI drivers and catalyst programs, then using a clean sweep type program to root out anything else that's ATI related, and reinstalling all the current drivers and software suite for ATI. Nothing works.


See More: Catalyst control centre not working

Report •


#1
November 18, 2009 at 18:51:47

You should not be on an admin account. Used to be guest was a security hole. Wonder if they finally fixed it.

Make a standard user and try it.

Might look at event viewer logs after you try to use app.

Might use system restore point to time when worked.

See if add and remove has repair feature.

Playing to the angels
Les Paul (1915-2009)


Report •

#2
November 19, 2009 at 04:17:25

too my knowledge, catalyst converter for win 7, is only for high spec cards, i use an old x700, and win7 does everything i need to do except theater mode. just wonder why you would need it?

the blocked accounts can be unblocked simply by changing the user rights., i noticed some on my computer, thought it may have been due to doing an upgrade..however giving my account rights worked fine.

the desktop problems, i suggest a system restore to the earliest restore point, or drop in the win 7 dvd and run a repair of the installation,
sounds like you may have messed up some files with installing catalyst and ati drivers..

i hate computers!
but cant help myself....


Report •

#3
November 19, 2009 at 04:26:29

Thank you for your help.
I tried all of those things and it works fine on any other account than the original admin account. I want to say it's an admin account because that was the one windows created when I first installed it. There were no other active accounts when this problem started happening, and any restore actions don't help it, probably because none were created prior to this happening.
Maybe the problem could be that I'm using an rtm version of win7 ult. Its past its date now and I read that windows will start to give you problems after the pre-release expires.
I have a brand new formatted drive waiting for the installation of a retail win7 that I am installing today when the mail gets here.
Do you think that will clear up the problem? I seriously keep my system clear of bs that will corrupt it, yet this stuff is happening. Could this problem be deeper in nature, such as there not being all the fixed drivers available because of my hardware being newly released?
I built this computer from scratch about 3 weeks ago, and as far as configuring bios goes, I just let windows do all that. Win also found and installed every driver(there were like 30 of them)when I powered up for the first time. Maybe I neglected certain fundamentals?
Whatever the problem is, absolutely nothing helps. In my event log all of the entries are for the catalyst control centre trying to load. It mentions a file called mom.exe, but that's running already. This is frustrating.
If i create and use another user account, and this problem no longer happens anymore, would that be a solve-all for this? Doing that makes me feel like I'm just polishing a turd..
****now it just gave me an error saying that windows security center has stopped working, and the system crashed and rebooted. Upon starting, it stopped me for a ChkDsK, saying it is strongly recommended that I continue. A few things were deleted and then it would not finish the boot after it completed chkdsk. I had to power off manually and restart. here I am again hoping I can submit this before the next crash.
If, for some reason, a virus is to blame for this(I think that because for the first few days after building this my Norton would need to be updated daily and turned back on) would installing a brand new win7 OS on my empty hdd clean the system of any virus, if I format the old drive once I move important files from there to the new one?
Any help you or anyone else can offer me would be greatly appreciated.

Report •

Related Solutions

#4
November 19, 2009 at 04:29:48

Princecorum, thank you for your response.
My GPU is an ATI Radeon 5870. Catalyst is a very useful tool for that video card, and I kind of need it, but ultimately can do without. See my last post and if anything makes sense let me know!
Thanks everybody.

Report •

#5
November 19, 2009 at 13:31:23

if it works fine in non admin accounts, create a new admin account, control panel/accounts/create new account,( you will need to be in the original admin account to do this) switch user into the new admin account and then delete the original admin account.
this should fix any issues if its just an account issue.

i hate computers!
but cant help myself....


Report •

#6
November 19, 2009 at 13:37:08

as too installing a new drive and formatting the old drive, i would format the old drive first (just in case it is infected) install the new drive, setting it to master, and install win 7 from scratch on the new drive..this is a personal opinion as i dont keep anything important on my c: drive, swap all files to an external, and backup to an external drive too.

i hate computers!
but cant help myself....


Report •


Ask Question