Articles

Intel ISA Config Utility (ICU)

December 5, 2005 at 09:10:48
Specs: windows 3.1, PIII/256MB

I'm having trouble installing Intel's ISA Configuration Utility (ICU)v1.43 for win3.1 used to config PnP. I followed the instruction, but in the last step don't see SETUP on the diskette. In fact, I did not see a setup file anywhere in the archive expansion process. If you have gone through this, help would be most welcome.


See More: Intel ISA Config Utility (ICU)

Report •


#1
December 5, 2005 at 10:59:04

According to Intel "Software to help you configure system resources with non-plug and play capable operating systems" and they have versions for DOS and win3.1. This is not just for NIC, I gather.

When expanding the wicu143c.exe archive, I noticed that there were several errors "warning, incorrect password for file..." and the files was not expanded. Anyone know what the problem is?


Report •

#2
December 5, 2005 at 11:22:21

INSTALLATION:

The R1.43 Windows ICU is distributed as the compressed file WICU143C.EXE,
which contains all the files necessary to create the installation diskette
for the Windows ICU. You are allowed to decompress the files if you agree
to the terms of the above license.

To decompress the R1.43 Windows ICU, copy the file WICU143C.EXE to an empty
directory, then execute the file at a DOS command prompt using the syntax
below exactly as it appears:

wicu143c -d -sWICUm19v

After decompressing the archive, delete it from the directory. Copy all the
remaining files to a blank diskette with the DOS XCOPY command:

xcopy *.* a: /s /v

The Windows ICU can now be installed from the diskette by executing the
A:SETUP program from the Windows Program Manager or Windows File Manger


Report •

#3
December 5, 2005 at 11:51:11

I followed the instructions you posted, identical to the ones that are in the readme.now with the archive. The problem is in the expansion step (wicu143c -d -sWICUm19v) in which I get several incorrect password warnings and several of the archived files are not expanded. I tried the expansion in Dos6.22 as well as in win2k's dos window. If you have a moment or two, can you try the expansion and see if you get the same errors. Thanks, P&S, for your help.



Report •

Related Solutions

#4
December 5, 2005 at 13:49:08

I am using XP at present, download wicu143l.exe to an empty folder:

http://developer.intel.com/design/motherbd/gen_indx.htm


Double click the file and it will self extract two files:

WICU143C.EXE
README.NOW


In CMD.EXE (NT Command Prompt) type:

wicu143c -d -sWICUm19v

Press enter and files extract, you then copy extracted files to floppy and within W3 you run setup from the floppy.


I will try again on a MS-DOS6 PC if you have further trouble.



Report •

#5
December 5, 2005 at 18:27:12

First, my apologies to readers of this forum for the excruciating detail. I would take this off forum, but the forum rules say as initiator of this thread I cannot send private messages.

P&S, I followed your steps exactly, but in win2k. As before, I got only 3 files out of the expansion by PKSFX <R> FAST! Self Extract utility. A typical line of output, in fact, the first:

PKSFX: <W14> Warning! Incorrect password for file: _MSSETUP.EX_

No file was extracted for this line.
Did you get all the files to extract without error? what is your file count?


Report •

#6
December 5, 2005 at 23:39:49

The file is "self extracting" you do not need to use 3rd party software, WinRAR gives the errors as well.

Report •

#7
December 5, 2005 at 23:43:48

Are you using the DOS or W3.xx version from the Intel page I listed ??

http://developer.intel.com/design/motherbd/gen_indx.htm


Report •

#8
December 6, 2005 at 00:29:22

Check your email please...........

Report •

#9
December 6, 2005 at 07:02:40

Thanks to P&S and x86 for your help. I was able to get Intel's ICU installed in win3.1 using the Winimage file you sent. :)


Report •

#10
December 6, 2005 at 08:33:08

Yes, it is not the nost intuitive software package on modern PC's...........

Report •

#11
December 7, 2005 at 07:21:35

P&S - Of academic interest only: why did your expansion and mine of the *same* Intel ICU file v1.43 give errors but not x86's expansion which worked flawlessly?

Report •

#12
December 7, 2005 at 08:40:11

Under Windows download 'ICU for Windows* 3.x, version 1.43' file "wicu143l.exe" to a folder, the double click file to self extract the following:

WICU143C.EXE
README.NOW

Within COMMAND.COM change directory to where the files have been extracted and type:

wicu143c -d -sWICUm19v
.....press enter

delete from above directory the following:

del wicu143l.exe
.....press enter
del WICU143C.EXE
.....press enter
del README.NOW
.....press enter

Type:

xcopy *.* a: /s /v
.....press enter


This will then create the SETUP floppy...


Report •

#13
December 7, 2005 at 19:43:18

Perhaps I misunderstood your earlier post. Did you also get errors during the expansion
wicu143c -d -sWICUm19v ?



Report •

#14
December 7, 2005 at 22:38:35

No erors whatsoever, though it does take a long time to auto write the files to floppy.

This was using XP COMMAND.COM and also undertook in CMD.EXE to test the archive.

I suppose the real test would be to undertake creation under MS-DOS6.22..


Report •

#15
December 8, 2005 at 10:17:32

Been There, Done That. In Win2k and DOS6.22 both gave errors. Downloaded the windows v143 archive twice!! I wonder if my NAV, Linksys router or ISP is/are tampering with the file as it is downloaded. EXE files are viewed with some hostility by well intentioned "firewalls" due to their ability to carry various nasties. I know my ISP has stripped a few attachments from email, but they usually tell you they have.

Again, a big thanks to you, P&S, and x486 for taking the trouble to help.


Report •


Ask Question