Articles

windows 2008 - SSTP VPN client side problem !

October 4, 2011 at 15:40:46
Specs: Windows 2008

Hi ,

I setup SSTP vpn server on Windows 2008 Standard R2 , and everything is working fine .

There is an issue on client side , when they are connected and trying to open more than 2-3 websites at same or downloading a file .

the ping time will increase on there side and after that they start to get request timed out !

and when they stop downloading or vist only 1 or 2 websites , they will have ping and time will decrease !

Really weird problem !!! couldn't find anything related to this problem on google !



See More: windows 2008 - SSTP VPN client side problem !

Report •


#1
October 6, 2011 at 13:50:26

Is the vpn connection the same one used for the internet browsing?

Most of us would never allow open internet browsing from the server due to the risks such operations would pose to the server and business network.

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's


Report •

#2
October 6, 2011 at 14:32:36

Yes , Internet browsing is allowed . the main purpose is internet browsing trough server , but when clients open more than 3 websites at same time our start downloading , they start to get request timed out in ping and almost pushed to no internet connection .

Any ideas to make any changes in setting to solve this issue ?


Report •

#3
October 6, 2011 at 15:25:06

You didn't answer my question

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's


Report •

Related Solutions

#4
October 7, 2011 at 01:06:38

Actually I didn't get you , but I want clients to use server's internet connection .

Report •

#5
October 9, 2011 at 13:30:16

If the users are using the same internet connection to come into the server and go out to the internet you have doubled the traffic load PER USER. This means when you have 5 users you have 10. When you have 50 users you have 100.

You either need two pipes, one for the ssl connection and one for outbound network browsing or you need a much largre pipe to the internet than you have now.

Make sense?

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's


Report •

#6
October 9, 2011 at 14:43:12

yeah , but that's not the issue , even when only one client is connected it will happen , with 100MBPS internet connection , one pipe for both inbound outbound traffic . I mean , I think its configuration issue !

I tried it with 1-2 users and 100MBPS connection !


Report •

#7
October 9, 2011 at 20:37:26

You have a 100mb connection from the server to the lan interface of the router.

This does NOT mean you have a 100mb connection to the internet.

with no one on, run an internet speed test to see what your actual up/down internet speed really is.

how much memory does the server have and what os 32/64 are you running?

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's


Report •

#8
October 10, 2011 at 00:33:55

Yeah , my internet connection is 10MBPS , but as I said this problem occurs even when only one user is connected . It has 2GB memory and OS is windows 2008 Standard R2 SP1 X64 . and processor is Intel E6300 .

But still I believe its configuration issue !


Report •

#9
October 11, 2011 at 07:07:13

2gig of memory is too low for 2008. Should be around 6gig for starts especially with x64. How the system is setup physically is part of the configuration.

Your connection may be advertized as 10mb but even if it was [and you did not conduct the tests I recommended] you only get half [or less] that for upload.

Unless you are running some kind of proxy server or network limit software, both of which are 3rd party I don't know of any native to 2008 configuration that limits internet bandwidth at the server.

You mention vpn users but I suspect there are also local network users also using the internet bandwidth.

Might run the speedtests as recommended and post the results

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's


Report •

#10
October 16, 2011 at 14:35:53

zigma4000 i have same problem

it not about server bandwidth or cpu or ram this problem it just a config problem

i have win2008 vps with just 512 ram

when i connect to vps with pptp vpn every thing is ok - speed is ok .

but when i connect to vps with sstp vpn its same as u say when client open more than 2 page ping will go up badly and finally request time out .

if any one find solution please help me too

web search email harvesting before you post your email address in a public forum

edited by moderator: spam prevention


Report •

#11
October 16, 2011 at 14:46:28

mine is dedicated server ! and its weird ! I believe it has nothing to with resources .

I hope someone will have solution for it !


Report •

#12
October 16, 2011 at 15:05:31

this is my client tracert for 4.2.2.4 in pptp mode ( pptp vpn to 64.186.134.42 is connect )

Tracing route to 4.2.2.4 over a maximum of 30 hops
1 276 ms * 278 ms 192.168.55.1
2 * * * Request timed out.
3 278 ms 278 ms 278 ms 64.186.134.1
4 278 ms 279 ms 277 ms 65.75.240.137
5 279 ms 276 ms 277 ms 207.210.95.93
6 278 ms 278 ms 279 ms atl-core-f-p2.gnax.net [207.210.95.254]
7 282 ms 282 ms 286 ms atl-bb1-link.telia.net [213.248.104.109]
8 288 ms 299 ms 293 ms level3-ic-124758-atl-bb1.c.telia.net [213.248.68
.54]
9 292 ms 288 ms 292 ms ae-21-52.car1.Atlanta1.Level3.net [4.69.150.67]
10 290 ms * 289 ms 4.2.2.4
Trace complete.


and this is same client tracert 4.2.2.4 after sstp connect to 64.186.134.42

Tracing route to 4.2.2.4 over a maximum of 30 hops
1 409 ms * 3388 ms 192.168.55.1
2 * * * Request timed out.
3 289 ms 1291 ms 356 ms 64.186.134.1
4 1721 ms 1233 ms 1273 ms 65.75.240.137
5 618 ms 330 ms 1394 ms 207.210.95.93
6 1357 ms 653 ms 888 ms atl-core-f-p2.gnax.net [207.210.95.254]
7 1253 ms 1296 ms 853 ms atl-bb1-link.telia.net [213.248.104.109]
8 513 ms 596 ms 708 ms level3-ic-124758-atl-bb1.c.telia.net [213.248.68
.54]
9 577 ms 798 ms 817 ms ae-21-52.car1.Atlanta1.Level3.net [4.69.150.67]
10 2900 ms 604 ms 717 ms 4.2.2.4
Trace complete.

what is the problem ???
when i connect sstp my speed going to be zero :(

please help


Report •

#13
November 20, 2011 at 02:10:27

Hello,
I want to configure a SSTP VPN server on 2008 R2. I followed several guide but i could not sucsess.
Can you help me with an instruction or tutorial?

Report •


Ask Question