Articles

Very slow SATA drive performance

February 26, 2005 at 15:50:32
Specs: W3K, P4 2.8 / 512MB

Hi everybody!
I will appreciate any sugestions on my unbeatable problem.
I am administering a small company lan 8PCs all with XP SP2, server 2k3 enterprice. The server PC is with P4 2.8GHz, 512M DDR400, ASUS P4C800-E Delux and 160G single SATA drive. Recentlly I have noticed a slow data transfer b/w the server's logial drives. I have run a HDD performance test with Sandra 2005 lite, and the results astonished me. It was smth. like 65MB/s on sequential read and 7MB/s ??? on a sequential write. I thing this is not normal about a SATA drive, isn't it? Can some one help what could be the reason?

See More: Very slow SATA drive performance

Report •


#1
February 27, 2005 at 05:22:27

First, check to ensure you have the most recent drivers for the SATA drive. If you don't you should be able to get them from the OEM's web site. If you don't, download and install them and see if performance doesn't improve.

If that doesn't fix things, you may have a bad drive or controller. Contact your manufacturer and verify your warranty (whether or not you have any), you may have to replace the drive.


Report •

#2
March 1, 2005 at 13:00:57

I would think you'd be searching for an updated driver for the SATA controller, not the drive.

"...but in my defense, it was dark, I was drunk, and it was delicious!"


Report •

#3
March 2, 2005 at 08:14:42

My bad, plz excuse me....I meant controller.....

Report •

Related Solutions

#4
March 3, 2005 at 00:15:06

Ok, here are the last things i have done!
I broke my warranty sticker to open the PC. SATA drive is connected to SATA1 plug which belongs to the intel's ICH5-R contrller. The south bridge is 82801ER. Nothing strange up to now. I saw that W2K3 recognizes the IDE/ATA controller as 82801EB. This seems to be the problem! I went to intel's site and downloaded the last version of intel chipset installation utility, which they claim is also for W2K3 and chipsets up to 925X. I have installed the utility! It requested to restart the PC. After system start up, nothing has changed. I started the new hardware wizard, but nothing new was found. I tried to update the driver of IDE/ATA controler from Device manager, but W2K3 didn't found more suiable one. I tried to choose one manually, but the only compatible devices were just 82801EB that W2K3 has listed. Shortlly speaking, W2K3 was behaving such like nothing has happend. I am really stucked up now!!

Report •


Ask Question