Articles

Remote connections keep dropping

September 28, 2009 at 15:53:45
Specs: Windows Server 2003 R2

Hey everyone I need some help with remote connections. My Windows Server 2003 runs fine. I've installed Dynamics CRM 3.0 which also works great. I set up VPN and this is where the problems began. From my office I'd connect to a neighbours network, and test VPN which worked. I'd then go home and it would give error 800 couldn't connect. I'd go back to the office change things in my router and it would work, but then same thing get home and it wouldn't. Now it's doing something odd, from home I can connect to dynamics CRM and gotomypc.com randomly, but if I try to VPN in, everything stops working, my dynamics, vnc, gotomypc everything. About 10 minutes later it comes back up and works then 30 minutes later it stops again. Trying to connect to VPN causes it to stop for 5-10 minutes guaranteed everytime. It doesn't make any sense to me, does this sound like a router issue or something in config? I'm not good with logs so not sure where to even begin to look, but it's almost as though when I try to connect with VPN, it triggers something to halt all incoming connections to the server and then resets after awhile. Anyone have any ideas?

See More: Remote connections keep dropping

Report •


#1
September 28, 2009 at 15:57:48

You test in three places according to your post
Home
Work
Via your work neighbor.

All work except at home. Right? Sure points to an issue at your home.

Might try a coffee house hot spot to see if it works fine.


Report •

#2
September 28, 2009 at 16:00:54

Sorry let me clarify, while in the office connected to my office network which the server is on, it works non stop, doesn't drop.

While at the office I connected to my neighbours, tested it and it worked but about 5 minutes later it would drop, so I tested it at home same thing. So basically any time I'm not on my work network it does that.

What I find odd though is that I subscribed to gotomypc.com as a failsafe while I'm at home, but this is the exact same. It works but then 5 minutes later or what not, it stops as well and can't reach my server at all.


Report •

#3
September 28, 2009 at 16:11:34

Does your vpn server have two nics?

I see no mention of opening vpn ports in the router.

http://www.windowsnetworking.com/kb...


Report •

Related Solutions

#4
September 28, 2009 at 16:15:30

Yes it has 2 nics, I tried with one then added another. Port 1723 has to be open on the router for PPTP I'm pretty positive, it was like that with Server 2008 and Mac OS Leopard server. I'm just not sure if it's VPN or not, because I can VNC in or use gotomyPC and it works for longer, like 30 minutes to an hour then might drop randomly. But if I connect the VPN, the second I hit connect, everything does, gotomypc dies, dynamics everything. I can't reconnect for 5-10 minutes then it will let me. Attempt to VPN in and bam it all shuts down again.

Report •

#5
September 28, 2009 at 21:00:21

Have you checked the server event log for entries concerning PPTP?

Report •

#6
September 29, 2009 at 05:28:45

No I haven't, where do I go to find that? I found Event Viewer under administrator tools, but it just shows Event Viewer (Local) then under that
-Security
-System
-Directory Service
-DNS Server
-File Replication Service
-Internet Explorer

Where would I find that? Just an update as well, it seems more like a fluke when the connection has dropped the one or two times I was just connected over VNC. Attempting to connect to VPN seems to be the real cause for it all to drop. The thing I don't understand is, is there no way to clear all the remote routing setup? Like I made so many changes when trying to fix things, then I uninstalled that role, reinstalled it, but all my settings remained. I changed a bunch of them tried other things, reinstalled, and they're still there. The odd part is that the VPN has worked a few times before. Right now it always gives Error 800 can't create VPN tunnels the vpn server might not be responding. This is after it says verifying username and password on PPTP, then tries SSTP or whatever the other one is. Then other times when I'd change some settings, I'd get Error 600 I think it was, and it would actually say that time couldn't connect because the sercurity protocols I'm atempting to connect with don't match the server, then after a few tries its back to Error 800. If I could just reset all the settings back to default it might work.


Report •

#7
September 29, 2009 at 05:31:33

Just a quick update, I was connected to my server doing VNC using it a bit, while writing my above post. Was connected maybe 15 minutes, then I went back to it, loaded firefox to download a file then few seconds later the connection died again. That's why I keep wondering if something in the router is corrupted and I should reset it all or try another router to rule that out.

Report •

#8
September 29, 2009 at 07:15:46

Check, whether the port UDP 500 is also configured in the routers firewall.

Check the routers log for errors.
Check the router settings.
Check whether there is a firmware update available at the manufacturers homepage.
Check also the FAQ on the manufactorer homepage for this issue.


Report •

#9
September 29, 2009 at 07:23:51

Thanks for the suggestions. I didn't see any errors in the
router when I checked, I can post the security log but it
doesn't really seem to match the times I've had issues. I'll
check for firmware update. The weird thing is originally I had
Mac OS X Leopard server and for VPN I opened port 1723
for PPTP and it worked perfect. Eventually all my users
were PCs so I thought Windows Server would be easier so I
did a trial of Server 2008. Here too VPN worked fine on
PPTP under port 1723 but my install had issues so I finally
gave up and went back to old Server 2003. Enabled VPN
left 1723 open and you know the rest. I'll open 500 to see
what happens but I think it might be open. The thing I don't
get though is gotomypc.com shouldn't need ports open since
it's over the internet, but that goes up and down too. I was
using it today and like I said started downloading a file in
firefox, and connection dropped. That was almost 2 hours
ago and it hasn't come back up, so this is so confusing. I'll
check for router updates and like I said I might try another
router just to rule that out. Where is the PPTP log located?

Report •

#10
September 29, 2009 at 07:50:27

I don't know, how you have configured your PPTP server, but try to connect to the network card, configured for PPTP by connecting a client pc to the switch, where the servers network card (PPTP) is connected to and try to connect via PPTP.
You might have to configure the ip address of the client pc with an appropriate ip address.
If this connection will not drop, the router or your ISP might be the issue.

Report •

#11
October 1, 2009 at 06:05:43

Hey everyone,

This is so frustrating, I just had it working.

To paulsep, the server is connected to my router directly, and client PCs connect to the router. The odd thing is that while I'm connected that way in the office, I can VPN in. Not to my local IP, but still to my VPN server vpn.companyname.com which forwards to my static IP address. As soon as I get home nothing.

I wanted to try my linksys router to rule out that the Belkin is screwy, but I didn't have the power adapter, so I did a firmware update on the belkin and reset it to factory and set it up again, but still does the same thing. The odd thing is I had Mac OS X server, then Windows 2008 Server before going to 2003, and I had no issues with either of those, just port forward 1723 PPTP to 10.0.0.50 my servers IP and it was good to go. Connecting with VPN now doesn't seem to kill the connection as much, as I just tried and was able to keep gotomypc.com connected the whole time. Is there a PPTP log somewhere I can check to see what's happening? Again it DOES connect so should be something in the log. Basically the flow is:

- I click connect
- Connecting to vpn.companyname.com on WAN mini port (PPTP)
- Verifying user name and password
- Connecting to vpn.companyname.com on WAN mini port (SSTP)
- Connecting to vpn.companyname.com on WAN mini port (PPTP)

Then the Error 800, the vpn tunnels could not be created.

What's SUPER frustrating is as I was writing this I tried it and it connected! I stayed connected for 45 mnutes, then disconnected to test it, and what do you know, its back to the start, Error 800. Like this makes no sense!
-


Report •

#12
October 1, 2009 at 08:48:05

"the server is connected to my router directly, and client PCs connect to the router."

You can't have two server nics going to the same router/subnet as the pcs. You should not be able to vpn to the vpn server via the local subnet.

Might want to review this;
http://technet.microsoft.com/en-us/...

I think you would be way ahead of the game if you just got yourself a vpn router and just loaded its vpn client software on the devices you use to access the network remotely.


Report •

#13
October 1, 2009 at 08:54:12

K my thing is I had it both ways before. When I had Mac OS
X server it only needed one nic connected to my router,
worked fine. When I had Server 2008 it was the same thing.
I went back to Server 2003 so I could use dynamics CRM.
The only reason I put a 2nd nic in there was because the
wizard said to auto configure VPn you need 2 nics otherwise
you have to do custom config. Right now it's back to just 1
nic not 2. What I don't understand is like I said, from the
same subnet in the office I can vpn into the server. From
home, it worked this morning once on my windows 7
machine then never again, then 10 minutes ago it worked
from my Mac but when I disconnected and reconnected it
won't work again either. So what I don't get is that
sometimes it does connect just rarely, but I don't see how
the server can be configured wrong or what not if it allows
me to connect.

Report •

#14
October 2, 2009 at 05:57:51

OK I didn't read all the posts but try and keep it simple. When troubleshooting things tend to get confused and just too much. Focus on getting it to work from home, since that seems to be the toughest. I'dd suggest you pull any routers or such you have at home and plug in the PC directly to the internet if that's possible. Be sure to have port 1723 open in the Windows firewall but nothing else. Then use Windows built-in VPN client and try to establish a VPN connection. Does it work? No- Problem lies with the server-side. Yes- Problem lies with your home-router.

If the problem is on the server-side I'd check for firewalls, maybe built-in in any antivirus programs you use, or the windows firewall, or the RRAS firewall, or router firewall. Do the same thing here, unplug any routers and use win 2003 as router, enable firewall and open only port 1723.

Keep it simple, my best tip.


Report •

#15
October 3, 2009 at 14:26:09

Hey everyone, still have to test another router but just as a last resort I may go for a VPN router. Here's the thing though, I already have a really good router and set up. Is there a way if I buy a vpn router, that I can connect it and use it with my current router? Like could I connect it to one of the ports on my current router and have it connect with DHCP so it gets a local IP, and then also have it dish out a range of local IPs as well that are different from the ones being given out from my main router?

Report •

#16
October 4, 2009 at 10:35:55

Hey everyone I think its finally fixed! I was able to finally go to my office and switch the router to my Linksys one. Set it all up, connected to neighbours network and tried to VPN. Worked right away. Disconnected, retried, worked 5 times in a row. Before on the rare occasion that it did work, it would never connect again after. I'm now at home, just connected and disconnected 3 times in a row and then again just now and it worked every time! Seems to be that stupid Belkin router I had, so thanks everyone for all your help much appreciated!!!

Report •


Ask Question