Drive is suddenly unformatted

January 25, 2006 at 19:17:24
Specs: Windows 2000 Pro, 1.6GHz P4, 512MB

Okay, this is a long, long story. I have two hard drives, one 40GB (split into two partitions) and one 160GB (all one partition). Up until yesterday I had the 160 one as a master and the 40 as a slave and had Windows XP installed on the 160. On the first partition of the 40GB drive, I had some data. Then, yesterday, I wanted to switch over to Windows 2000 because of Windows XP's problems with Firewire hard drives. For a long time I had also wanted to change things around so that the 160GB hard drive was the slave and the 40GB drive was the master; the 160 could have all my documents and the 40 could have the OS and program files.

First I tried just using the second partition on the 40GB drive for Windows 2000, but I decided I wanted the full drive for program files, so while I was in 2000, I moved the files on the first partition of the 40GB drive onto the 160GB drive and removed the Windows (XP) files from the 160GB drive so that when I reinstalled Windows 2000 on the full 40GB drive, the boot loader wouldn't give me the option to load Windows XP when I didn't want it anyway.

Okay. At this point I also went inside the computer and switched the master/slave configuration of the two drives so that the 40GB was the master. I restarted, installed Windows 2000 on the 40GB drive and all was going well. Since then I upgraded to SP4 (as there were no Service Packs on the setup disks) and installed some other programs, all along, being able to access the 160GB hard drive, which still had my documents on it from before I removed Windows XP. (Observant readers will probably notice what I suspect might be the problem by now.) Anyway, everything was going fine.

Then today I transfered some large files onto the 160GB hard drive and that worked fine. Suddenly, after the last transfer, I was no longer able to access folders on the 160GB drive. I thought that was pretty weird, so I tried restarting. After a reboot, Windows doesn't even recognize the drive as being formatted and asks me if I would like to format it (which of course I say NO to).

Now I was pretty freaked out, as the drive is less than a year old and it had been working perfectly. So I went online to search for NTFS restoration tools and downloaded Restorer2000 Demo, which is scanning the drive right now. Then, I noticed something strange(r). The partition size listed in Restorer2000 is 149GB, which is what it's supposed to be, but the *device* size is only 128GB. Then it snapped in my mind - yesterday I was reading/writing/deleting files on the drive with an un-updated Windows 2000, and Windows 2000 didn't support drives over 128GB until SP2 was released. So, I get the feeling that might have something to do with the problem, and I'm hoping no irreparable damage has been done. What problems can come up if an OS with only 28-bit LBA writes to a drive larger than 128GB? If that is a possible cause for this problem, what can I do about it?


See More: Drive is suddenly unformatted

Report •


#1
January 25, 2006 at 19:43:47

Correction: I guess the 48-bit LBA in Windows 2000 wasn't enabled until SP3, not SP2. Doesn't really change anything though I guess.

Report •

#2
January 26, 2006 at 17:48:41

1. Try EASEUS DataRecoveryWizard to recover data.

2. Install win2000 sp4.


Report •

Related Solutions


Ask Question