C0000218 Registry File Failure

April 9, 2008 at 19:44:54
Specs: Windows 2000 Pro, Pentium III
Hi there! I have recently upgraded my RAM from 256mb to 512mb, and everything worked fine yesterday. This morning, I experienced the following error when I start up my computer. I have not been able to fix it.

STOP: C0000218 {Registry File Failure} The registry cannot load the hive (file):\System Root\System32\Config\SECURITY or its log or alternate. It is corrupt, absent, or not writable.

After getting pass the Windows 2000 loading screen, a blue screen appears with the error and the system reboots. I have shut off my computer numerous times and turn it back on only to get the same results. The error repeats and my system constantly reboots after the Windows load screen, getting no where.

Here is what I have tried:

*Safe Mode--The error still persists.

*Taking out the memory and going back to 256mb---After doing this, I rebooted in "Last Known Good Configuration" and was successful to get it to boot normally but my documents are gone and the programs in my start menu have disappeared. Also, my harddrive space was 10 GB before I did this, now it has gone up to 15 GB. (How did this happen????)

*I put the 512mb back in, and the error returned.

I really want to keep the 512mb upgrade, and these problems are frustrating. Please help! Thanks in advance. :)


See More: C0000218 Registry File Failure

Report •


#1
April 9, 2008 at 23:02:30

Report •

#2
April 10, 2008 at 00:57:58
Since the STOP: C0000218 error disappears when you remove the 512mb module........

For all of the following, if memory errors caused by the 512mb module being installed are serious enough, that can certainly cause data loss on a hard drive.


I suspect
Most likely:

- the 512mb module is not compatible with your mboard.

I know from experience that can generate false errors, and weird stall and rebooting problems.

Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard and it's chipset.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
http://www.computing.net/hardware/w...
Correction to that:
Mushkin www.mushkin.com

- or the contacts on the 512mb module have something on them that is causing a poor connection.
You may sometimes get the IRQL_NOT_LESS_OR_EQUAL error from this, or memory dumps.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:
http://www.computing.net/hardware/w...

Much less likely:

- or you have a poor connection problem in the slot you put the 512mb module in.

Try the 512mb module in a different slot(s) than you had it in before.

Extremely unlikely:
- the 512mb module is bad.

Download a ram test and test the ram.
e.g. memtest86.
One complete pass is enough to detect whether the ram is faulty, or faulty only when both modules are installed.
Test each module, then both, and try at least one module that tests okay in all slots to rule out a bad slot.

HOWEVER

If you do a ram test, do that AFTER having tried cleaning the contacts and making sure the ram is seated properly - otherwise any errors found may be FALSE.
If the ram is incompatible with the chipset, it will likely FAIL a ram test - that is NOT a true indication of the ram being faulty - there is probably nothing wrong with it, and it will pass the test if installed in a mboard it is compatible with.
.......


Report •

Related Solutions


Ask Question