ADPrep Issue

January 25, 2010 at 22:21:45
Specs: Windows XP
Hi all,

I am trying to install additional DC into the domain(consist of w2k n w2k3 server)..the adprep /forestprep and adprep /domainprep run successfully with no error..problem is no adprep is generated in the debug folder..
I tried to perform dcpromo on new w2k8 server but it keep prompting me to perform adprep at main dc, which i already done.
Also tried to re-run the adprep in w2k server but message saying process already been run...
anybody encounter such problem before? thanks

See More: ADPrep Issue

Report •

January 26, 2010 at 02:50:55
You will need to upgrade your functional level to 2008 to allow the 2008 server to be a DC.

*Note: Any existing Windows 2000–based or Windows Server 2003–based Domain Controllers in the environment will no longer function, and in fact, the upgrading wizard will not allow you to continue with the operation. Before raising functional levels to take advantage of advanced Windows Server 2008 features, ensure that you will never need to install domain controllers running Windows 2000-based or Windows Server 2003–based Domain Controllers in your environment.

Report •

January 26, 2010 at 05:22:24
Hi Micka,

Does that mean the w2k n w2k3 dc will no longer function in the domain? I just want to push in the w2k8 server as additional dc in the network, then slowly phase out the w2k dc..any recommendation?

Report •

January 26, 2010 at 08:48:22
Did you run the version of Adprep as found on the 2008 cd? You would not run the 2003 version.

Only if wanting to run RODC's are you required to be in the 2008 forest functional level.

review this

Report •

Related Solutions

January 27, 2010 at 01:52:42

Yes..I ran the version from W2K8 server CD...any advise what is the best way to do this,as in promote the w2k8 as dc and slowly bring down the main w2k server...thanks

Report •

January 28, 2010 at 14:55:30
Your migration plan should have addressed this question. The purpose of the migration is a key element. This decides what gets upgraded and why. The next question is what are the pitfalls.

Why do you feel you need to upgrade to 2008 AD?

Report •

February 11, 2010 at 18:10:23
You absolutely do not need to have a 2008 functional level to have 2008 DC. You can leave your functional level at 2000 if you want to. You will need to run the adprep and forest prep from the 2008 DVD.

You need to extend the schema to allow a 2008 DC to be entered but you do NOT have to raise the functional level. Check your current schema version. You need to be at schema version 44 to have a 2008 DC.

I don't mean to be a prick but you should really check your facts before you answer questions.

Report •

Ask Question