winsock has detected a problem with the winso

April 11, 2011 at 13:22:29
Specs: Windows 7
I ran an Avast and Avira scan on a Win XP PC. It removed HTML/Infected.WebPage.Gen virus along with a bunch of other viruses. But now the system doesnt connect to the Internet, giving MANAGED SERVICES AGENT HAS ENCOUNTERED A PROBLEM. Also running Windows Network Diagnostics leads to Windows has detected a problem on Winsock provider catalog error.
Has Avast removed too much? Please help!

See More: winsock has detected a problem with the winso

Report •

April 11, 2011 at 20:50:56
Try downloading from another pc onto a flash drive, then onto your XP pc.

Report •

April 12, 2011 at 01:49:28
Thank you very much for replying to my message. Just not sure what file(s) I would have to copy via flash from another PC. The Windows "MANAGED SERVICES ENCOUNTERED A PROBLEM" error had an error signature below:
szAppName: myAgtSvc.exe szAppVer:
szModName: msvcr80.dll
szModVer: 8.0.50727.3053.

Which files would I copy from the other PC? the ones shown above - exe and dll?
And would I just copy them to the same Windows folder as on the other machine (both machines are using WinXP but the machine with the error is SP3 - not sure of the service pack on other machine. Would it matter?).

Best Regards,

Steve Tennett

Report •

April 12, 2011 at 02:03:47
Winsockfix is a stand alone program designed to fix Winsock corruption.
I don't know about the files you mentioned but will see what I can find?

Report •

Related Solutions

April 12, 2011 at 04:12:43
I downloaded winsockxpfix and I'm going to try it. Will keep you posted on outcome.

Report •

Ask Question