Help re my USB ports please! Possible virus?

March 4, 2011 at 09:48:24
Specs: Windows Vista
Hello, a day or two ago, a window popped up on my laptop screen (apparently a message from Windows) telling me I had a multitude of viruses on my computer, but if I clicked on the link provided, that would resolve the problem. I have McCafe so ran a full scan, however, no viruses were found so I just closed down the 'Windows window' that had appeared.

Since then, all of my USB ports have stopped working, and a message has been coming up telling me that the USB device is not recognized and that it has malfunctioned. However, this is happening with every device I try. I went onto various forums and ran recommended programmes which told me that there was a multitude of errors on my computer, but that if I paid them all would be fixed and well.

When I look on the computer system and scan for driver updates, it tells me that the drivers are up-to-date despite what these other programmes told me online (the ones asking for money).

This is incredibly frustrating especially as I do not have great knowledge about computers. Can anyone please help??? Thank you in advance!

See More: Help re my USB ports please! Possible virus?

Report •

March 4, 2011 at 12:21:00
You shouldn't have touched the window at all, by doing that you have activated the virus to load on to your pc.Note this is a fake anti virus it will tell you all sorts of lies, to make you buy their fake cure. Which doesn't work.
You will need to download Malwarebytes onto your desktop from this link:
You may have to do this download in safe mode with networking?
Update and run a full scan in safe mode. If you have troubles getting redirected to a bogus AV site, check your proxy settings.start-control panel-Internet options-connections (tab)-lan settings.(make sure the Use a proxy server for your LAN is not checked)
If you have trouble downloading it on to your pc, try renaming it when you save it.
Now download SuperantiSpyware from this link:
Update and run a quick scan.
You should check your host file using the guide from the How To section:

Report •

March 6, 2011 at 17:06:17
Hi, thanks so much for your answer. I managed to resolve the problem. Thanks again!

Report •

March 6, 2011 at 18:47:46
You are most welcome. Thanks for getting back to me.

Report •

Related Solutions

Ask Question