xcopy folder disappearing?

Dell / Insperion 6400
January 20, 2009 at 03:29:42
Specs: Windows XP, SP3, 3GHz/2Gb RAM
Hi people,
I was wondering if someone knows what is going on...
I am using an xcopy command to back up some files from two local drives, C: and D: to folders on a mapped network drive O:
The problem I am having is that the data copied across from drive C: copies fine, but the data copied from drive D: to a specific folder on drive O: causes that folder on drive O: to disappear. I think it is still there as when i try to create another folder on drive O: of the same name it comes up with an error telling me there is already a folder of that name.

The commands i am using in the batch file are as follows:

xcopy /s /e /q /y /v C:\ICPCHEM\1\METHODS "O:Archive\Method Files"
xcopy /s /e /q /y /v C:\ICPCHEM\1\SEQUENCE "O:Archive\Sequence Files"
xcopy /s /e /q /y /v D:\ "O:Archive\Data Files"

As explained above the first two backups (Of the "Methods" and "Sequence" folders) backup fine to the specified folders in the O: drive.
The batch file seems to copy the folders on D: drive to the "Data Files" folder on the O: drive, but after the batch file has run when i explore to O: drive the "Data Files" folder seems to have disappeared.
Hope that makes some kind of sense. Anyone got any idea whats going on?


See More: xcopy folder disappearing?

Report •

January 20, 2009 at 04:37:05
If I remember correctly xcpoy doesn't like trailing backslashes on directory names. Of your three commands only one directory contains a trailing backslash, d:\ try using d: instead.

Also try the /k switch, I just did some testing and the folder seemed to be comming up with the hidden attributes??

This is very strange, I can't even reset the attribute in explorer without third party tools. Attrib seems to be able to do it.

attrib /s /d -r -a -s -h drive:\folder

Report •

January 20, 2009 at 15:07:21
Hi again Judago,
Cheers for trying to sort this out. Tried without the backslash and with the /k and the same thing happens.
I then tried the "attrib" command you wrote and it works a treat. The folder is now visible in explorer. You were right it must have been hardlocked on hidden somehow. Yesterday i did go to the folder options and show hidden files and folders but it still didnt show up.
Once again Judago you have saved me a major headache. Cheers again.

Report •

Related Solutions

Ask Question