Why does PPPoE keeps disconnecting?

August 16, 2015 at 03:59:37
Specs: Windows 10
I know there's a lot of questions like this, but I can't seem to find one that describes the situation I'm facing.
I'm using Win10 and a PPPoE connection.
Before today, every time it disconnects and I just click connect and it does the job. Some times it disconnects about 3-5 times a day, give or take.
However, today, no matter how many times I've tried to reconnect, or how long I've waited, it just gives me the same error: "unable to connect, check your modem or other connecting devices".
I thought it might have something to do with Realtek Family Controller's driver so I went and disabled then enabled said driver. After that, I connected to the internet and it worked, but for no more than about 10 minutes.
It has been like this for the whole day.
What happened?

See More: Why does PPPoE keeps disconnecting?

Report •

August 16, 2015 at 09:54:15
Wifi or Ethernet?

Have you tried the latest drivers for whatever you are using?

Sometimes switching the router off for about half a minute can help.

Todays problem could be the internet or server (so it might rectify itself). Worth contacting your server as they can check the line and so forth.

Always pop back and let us know the outcome - thanks

message edited by Derek

Report •

August 16, 2015 at 10:13:35
Faulty modem or router can also cause intermittent connectivity. Those can be challenging as they work, don't work, work etc.

Are you connecting through a high speed modem, then to a router, or just the modem?

Is it a modem/router combo all in one type device?

To err is human but to really screw things up, you need a computer!

Report •

Related Solutions

Ask Question