Vista PC not showing up on mac os

January 7, 2009 at 09:42:07
Specs: Windows Vista, Intel Core 2 Duo [4GB DDR2 RAM]
hi guys,
first of all excuse if my english isn't that good :D

Now to my problem: I have a 3-computer-home-network with a vista machine (cable) and two macs running leopard (wireless), all with manually assigned IPs.
The network itself works flawlessly, so I can connect to every computer from every computer - no problems at all.
My problem is that my macs don't recognize my vista pc automatically - so it doesn't show up in finder (=windows explorer) automatically but I have to connect to it manually with smb://IP.
It works fine the other way around (so I can see all computer from my vista pc).

I've been trying to figure this out for days now, but I just can't get it working all the time. Some things I figured out so far:

1) When one of my macs is the master browser on the network, it seems to work most of the time, even if it can take a long time for the vista pc to show up

2) When my vista pc is the master browser, it never ever works. So the two macs show up on my vista pc, not vista pc doesn't show up on any of my macs

3) Rebooting the vista pc when it is the master browser seems to work. one of my macs becomes the master browser and shows the vista pc after a little while

4) When my vista pc is the master browser, net view shows all the computers on the network correctly and "nbtstat -r" show the netBIOS names of my macs after a while. BUT "nbtstat -n" only shows my workgroup and my vista pc, none of my macs (don't know if it's supposed to)

5) when my vista pc is the master browser and I execute "net lookup master" or "net lookup VISTAPCNAME" on one of the macs, it works fine and as expected. when I executed "net usersidlist" however, it gives me the following error:

Could not get the user/sid list

... and I guess this is the cause of my problem. I'm not a network expert (not even nearly), but I guess net usersidlist is supposed to show all the computers on the network with their SID. And since this command failes no computers show up in my finder.

Any ideas on this? I really wanna solve this.


See More: Vista PC not showing up on mac os

Report •

January 7, 2009 at 09:55:38
... just noticed that "net rpc user" on one of the macs with the vista pc being the master browser gives me
Could not connect to server
The username or password was not correct
Connection failed: NT_STATUS_LOGON_FAILURE

net rpc user --user=Guest
works fine

edit: when one of my macs is master browser, executing "net usersidlist" from the other mac returns the same error as above, so that doesn't seem to be the root of it all.

Report •
Related Solutions

Ask Question