unable to contact dhcp?

Dell / Mp061
February 6, 2009 at 10:04:20
Specs: Microsoft Windows XP Professional, 1.997 GHz / 3070 MB
Hi, I am new to networking and am a bit lost and would appreciate any help. I have an epson stylus photo px700w printer. It is an all-in-one with a memory card reader. I had it installed and working but then I got a virus - mal-otorun2 which took me a couple of weeks to get rid of. I used Malwarebytes anti-malware and Normal malware cleaner. Anyway, the printer can be set up via usb and/or wirelessly. I have reinstalled it via usb but cannot see the memory card reader. I tried to install it via wireless but it couldn't find the network. My wireless internet connection is fine - no problems. But my LAN displays a 'limited or no connectivity' error message. I have tried disabling the windows firewall - no change, I tried the repair to renew IP - no change, I tried the netsh - no change, I tried the rebuild tcp stack fix - no change. I tried ipconfig/release and ipconfig/renew - no change. Here is the details from ipconfig/all:

C:\Documents and Settings\Photos>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : LAPTOP
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller
Physical Address. . . . . . . . . : 00-15-C5-52-E9-2E
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Connection
Physical Address. . . . . . . . . : 00-18-DE-70-27-6B
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DNS Servers . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : 06 February 2009 17:05:48
Lease Expires . . . . . . . . . . : 09 February 2009 17:05:48

Would really appreciate any help or insight anyone could offer - I'm stumped!!

See More: unable to contact dhcp?

Report •

February 6, 2009 at 10:20:41
If you are not using the lan connection disable it. This has nothing to do with your printer error.

Connect only via usb so its pc to printer direct. No wireless issues to deal with.

If you could print when connected via usb but you can't read the card reader I would contact Epson support to see if they have an idea.

I would suspect a failed card reader if everything else is working.

Report •

February 6, 2009 at 10:21:33
Only one NIC at a time needs to be enabled and the wireless NIC on your laptop is getting an IP address. If it's WEP encrypted, the key has to be given to the printer.

Give your printer a static IP address out of the DHCP range. Use for the default gateway and for the subnet mask.

I don't why people use DHCP for home networks, especially wireless. It gives IP addresses to anyone in the area. To make things worse, most people don't change the default password to the router. That's asking for trouble.

Report •

February 6, 2009 at 11:25:12
printer shouldn't have a gateway ip.
dhcp is OK if you limit the scope and do mac filtering/ip reservations

This printer connects physically to wireless router to print wirelessly.

Least that is what I get from here:

Report •

Related Solutions

February 6, 2009 at 12:01:52
Okay, thanks all for your replies.

I am still working on them. However:

Wanderer: I spent 3 days on with epson who eventually assured me that it was not a printer problem. I think that they are right as the memory card reader worked fine before. Also, I have no idea how to do MAC filtering and IP reservations?

guapo: I am not sure how to give my printer a static IP address and I don't know what a WEP is, sorry? But would really appreciate more info!

I tried to reinstall the printer with an ethernet cable (which I did when I got the printer and it worked fine) but it wont install this time as it fails to find the computers network.

Still stumped!!

Report •

February 6, 2009 at 12:17:00
wep key or wpa/wpa2 key is for encrypting your wireless for your own security and preventing others from accessing your network unauthorized.

mac filtering/ip reservations should be covered in your routers documentation.

To troubleshoot a printing issue EXCLUDE networking. This way with just a usb connection you only have to troubleshoot the pc and the printer.

If, when working with epson support, you had a direct usb connection to the printer and everything worked except the card reader... how did they explain the problem was not the printer?

You only load one driver for all right? So how did they explain that away?

Report •

February 6, 2009 at 12:22:36
There is screen and a key pad on the front of the printer. Go to network setup and set the IP there.

Report •

February 6, 2009 at 12:36:29
guapo why interject networking into the equation when the issue is the card reader in the printer? You are only complicating the issue.

Let's solve the card reader issue THEN move on to getting it networked.

Report •

February 6, 2009 at 12:38:22

Epson asked me to confirm using the printers own screen and keypad that it could access the files on the memory card, which it could. This meant that the reader was okay. And because the computer could scan and print this meant that the printer was functioning okay. They figured that it must be a software problem with the computer.

Guapo: can you please suggest a static IP address out of the DHCP range?

Report •

February 6, 2009 at 12:50:26
If you want to complicate this...OK

I would use for your printer assignment. This is the end of your ip subnet. At some point you should exclude that ip from your routers dhcp scope so you won't have a ip assignment conflict.

It would appear from what you describe that the printer is fine.

If so then you most likely have residual OS corruption from the virus. I have to assume you have no restore pointes before the virus attach.

Next logical step is a repair install of the OS, do all your service packs/updates and then install the printer with it connected to usb. Then see if you have different results.

Report •

February 6, 2009 at 13:01:31
Ah... I really don't want to complicate things, honestly! I understand that you say the printer and LAN network are two different errors. Right now I am trying to install the printer via ethernet to see if I can access the memory card reader. The printer has these settings (taken from printers own screen):
Connection: 100BASE-TX full duplex
Obtain IP Address: Auto
IP Address:
Subnet Mask:
MAC Address: 00:00:48:39:1B:9A

When I try to run the printers network install programme it can see the printer and reports that the IP address is not set. I then have two options - auto detect or set ip address manually - I have tried both and they both fail reporting network connection failed.

I think that the two problems are linked? Really appreciate your help with this cos I'm baffled!!

Report •

February 6, 2009 at 13:07:03
If they are linked its due to faulty hardware.. in the printer.

change the printer from auto to static
put for ip
put for subnet mask
leave gateway blank since the printer does not need internet access.

Once the panel reads like it does with those entries ping that ip from your pc.

who setup the router?

Report •

February 6, 2009 at 13:13:33
okay, trying that now. The printer is wired via ethernet straight into my laptop pc. My internet router is one I got from sky and I used the disk they supplied to set it up.

Report •

February 6, 2009 at 13:16:45
Okay, I input the ip you suggested into the printer via the printer screen. Then I tried to ping from my pc and it failed reporting 'request timed out'...

Report •

February 6, 2009 at 17:07:48
That is because you connected to your laptop.
You were to connect to your router with both your laptop [wirelessly] and the printer [via ethernet cable].

You would need a different cable [crossover] to connect like you describe. It would be OK if one of the devices supported mdi/mdix. And since you are not getting a dhcp address from the router you are going to a default ip address which the printer is not in [ping failed for two reasons: hardware and ip]

A network cable doesn't work the same way a serial, parallel, or usb cable do.

This is why I kept trying to point you back to doing it via usb. Less to complicate things, less to troubleshoot.

You choose. I can go either way. We might as well finish with networking since all you have to do is get it hooked up right so it will work.

Then try your ping test again.

Report •

February 7, 2009 at 04:00:41
Ah.... that would explain things then. I will give it a go. Thanks a lot for your help. I will try it now...

Report •

February 7, 2009 at 06:09:28
ah... I'm getting ready to throw this printer out the window. Okay... the printer installation instructions say that you have 3 choices to connect it via the network - 1.Via the router with the printer plugged into the router with the ethernet cable and the pc wirelessly connects to the router, 2. connect the printer via ethernet cable straight into the laptop (I know that you said that it doesn't do this - but that's what it suggests) and 3. connect with WPS (which I guess means wirelessly to router and laptop wirelessly to router).

I tried all 3 options and pc reports cant find the printer. I then assigned the printer the static ip you suggested. The first two options then find the printer but fail then with the error network failed to connect.
The third option also fails with the same error.

As far as I can tell - the laptops wireless connection is fine, the ethernet cable is fine, the router is fine, the printer hardware is fine. It all seems to keep coming back to my network??

Any ideas on how to fix this? Maybe if it was fixed first then I could connect to my printer okay?

Report •

February 7, 2009 at 06:16:13
We are up to 16 posts now. It might be time for you to ask someone locally to help you.

The only other thing I can tell you is to open the printer folder. Right click on the printer, left click on properties and go to the ports tab. What port does it say it's on? It should say TCP, not LPT1 or USB. If the printer isn't there at all, it's not installed correctly.

Report •

February 7, 2009 at 06:29:12
Yeah, the printer hasn't gotten as far as installing because it cant connect to the network, which I why I think it should be repaired first.

I know we are at 16 posts but please don't give up on me. I don't know who else to ask!!

Report •

February 7, 2009 at 06:49:58
The printer doesn't connect to the network. The network connects to the printer. The printer does nothing but waits for you.

Connect the laptop to the router with a cat5 cable. Then run the install CD. When it gets to the question of local or network, choose network and make sure you install it on a TCP port. Once you get it done that way, you can switch to wireless.

Report •

February 7, 2009 at 07:16:56
Okay, great.. Once I connected the printer into the router and then separately connected the laptop into the router the printer connected fine and even mapped the memory card reader as a drive. Brilliant!!

Now, as my router is in a different room to my office I need to setup the printer wirelessly - any ideas?

Thanks so much for your help on this..

Report •

February 7, 2009 at 07:29:32
Now, disable the wired NIC, enable the wireless NIC. The printer should stay mapped and you can send me a bottle of Crown Royal. I don't know what Wanderer drinks.

Report •

February 7, 2009 at 10:11:41

Absolutely! Beer is the least I can do. I feel that we are almost there. I just cant get the wireless to work. I went into the network connections and disabled the LAN - the wireless was already enabled. The printer does stayed mapped but results in a communication error - cant find printer. The printer is set on wireless and seems to be connected to the router (I took out the ethernet cables) but the computer cant seem to wirelessly connect to printer??

Report •

February 7, 2009 at 10:20:45
These days, printers have a web interface accessible similar to routers. Open a browser and in the URL box, type: if that's still the address. There maybe some tweaks that are needed in the networking section. Note the network name of the printer.

If you have to go back to the wired connection to open the page, do it.

Report •

February 7, 2009 at 10:41:55
Okay, I had to go back to the wired connection with a printer ip of

I typed that into firefox and got the web interface for the printer. It is really just a info display - no network options just this:
Printer Name : EPSON391B9A
Connection Status : 100BASE-TX Full Duplex
Obtain IP Address : Manual
IP Address :
Subnet Mask :
Default Gateway :
File Sharing : Enable
File Sharing Mode : Read Only
MAC Address : 00:00:48:39:1B:9A

There is a network setup programme with the printer software though. I've been using that to set it up. With the printer wired up via ethernet to the router the network setup programme can find the printer okay. It then offer a wired or wireless option. So I choose wireless and it picks up my sky router. I then put in the router key which I know is the correct one - it then passes these settings to the printer and tries to connect wirelessly - it fails to do so???

Report •

February 7, 2009 at 12:44:24
Router key as in the encryption (WEP) key? If so, that key has to be added to the printer setup using the printer interface.

Report •

February 7, 2009 at 15:33:35
Guys go back to the url I gave you to the printer docs.

according to them the printer HAS NO WIRELESS INTERFACE. Docs only showed a picture of usb/lan.

Which means you connect to the router from the laptop wirelessly and from the router to the printer WIRED.

this is an incorrect entry
Default Gateway :
it should look like this
Default Gateway : blank, nada, empty...

I am a Rip Van Winkle Bourbon fan :-)

You could connect laptop to printer with a cat5 netowrk cable but it would have to be wired as a crossover not as a patch which is straight through.

Back to working on prepping the garden...

Report •

February 7, 2009 at 16:45:35
If it has no wireless interface, then that's the end of the story. He has to wire it and that's it. Run a cable through the wall.

Report •

February 10, 2009 at 12:47:50
Hi Guys,

Thanks so much for all your patience and help. I finally got it all sorted. I thought that I would detail it just in case anyone else has the same problem.

The Epson px700W is a wireless printer that can be connected via ethernet (cable from printer into router) or via usb or via wireless. To set up printer I had to use the network software that came with the printer. I connected the printer via ethernet to my sky router and set the settings on my printer via its own screen. I used the static ip address you gave me ( so that the software could detect the printer. Once it found the printer I was able to choose to set it up wirelessly. The software then sends the relevant settings to the printer to turn the printers wireless connection on. Then the printer tries to wirelessly connect to the router. This is where I was having the problem - the printer could not make this connection. I phoned sky who gave me the username and password for my sky router. I was then able to go into my routers setup - into wireless setup and changed the channel from channel 1 to channel 6. Once I did this the printer was able to connect to the router and it mapped the memory card. So now everything is working great.

Thanks again for all your help guys.

Report •

Ask Question