TightVNC Failed to connect to server

December 12, 2009 at 16:21:19
Specs: Windows Vista/XP
I am trying to use tightvnc so I can access my desktop (in the basement) with my laptop wirelessly. I think I have it all set up properly, but when I try to connect, I get the error:

"Failed to connect to server"

Here's my setup:
Desktop (XP) vnc server
Laptop (Vista) vnc client

The router has ports 5900 and 5800 forwarded to

Desktop uses Comodo firewall, which I have disabled for testing.

The only other thing of note is that my desktop doesn't use any sort of password protection at boot up.

Any help would be appreciated.


See More: TightVNC Failed to connect to server

Report •

December 12, 2009 at 16:56:22
You are in the same local area network (192.168.1.x).
Therefore, you don't have to forward ports 5900 and 5800.

Report •

December 13, 2009 at 07:35:38
Bah, found the problem. The windows firewall had turned itself on (I don't know how, I turned it off ages ago when I installed comodo).

But as a followup, if I get rid of the port forwarding, no one from outside would be able to access my machine via vnc, it would only be accessible from within my LAN, correct?

Report •

December 13, 2009 at 14:21:23
Yes, correct. You did not mention, that you'd like to be able to access the VNC server from outside your network.
In that case, you need to forward the ports, at least port 5900, to allow access from the outside.
Port 5800 is only needed, if you want to allow access to the VNC server via web-browser.

Report •

Related Solutions

Ask Question