Strange wireless connection problem

Hewlett-packard Envy 17-1190nr notebook
January 19, 2011 at 06:39:06
Specs: Windows 7

I've been using a Buffalo Wireless-N Nfiniti router (WHR-G300N) for about 3 months for my wireless network without any problems - I've been using WPA. Suddenly my laptop (HP Envy 17) can't connect to the wireless network any more, but has no problems connecting to other wireless networks. The laptop finds the wireless network but cannot connect - I get an error-message.
I can connect my phone to the wireless network so this seems to be working and my desktop computer has no problem with accesing the Internet through a cable either.

I consider myself an above average computer user but I'm running out of solutions.

I've tried to upgrade the firmware in the router (to version 1.65)
I've tried reseting the router
I've tried unplugging the router for a longer period
I've tried reinstalling the network-card on the laptop
I've tried rolling back Windows 7 on the laptop to a date where I know it could connect (to avoid any updates screewing things up)

Hope anyone has a suggestion for a solution :o)

Kind regards

See More: Strange wireless connection problem

Report •

January 19, 2011 at 06:57:29
Try to change on the router the channel used to broadcast wifi signal. Usually by default that is channel 6 and it may be shadowed by interference from other sources. Try channel 11 or 2 at the edges of the band.

Report •

January 19, 2011 at 07:14:34
You are my saviour!!

Thanks a lot - that helped - guess you are way above the average computer user :o)

Report •

Related Solutions

Ask Question