Static IP behind DHCP router

October 5, 2011 at 09:41:49
Specs: Windows Vista
I have been assigned some static IP's from my ISP. They have set the next hop mac address to the WAN (FE0) port on my cisco router. When the wan port is on DHCP the network works fine. When I set the wan port to be one of my statics I cannot access the internet.

What do I need to change to be able to access an internal device (reserved address on internal side of network) from an outside IP. I know it will involve NAT / static routing which I "thought" I had setup!

Thanks for any help. Here is my config / network map

*All statics are made up

MODEM ----> Cisco Wan (97.64.64.57) ---> NAT / DHCP To 192 network -- Cisco Lan ---> Dumb Switch ---> Internal Server (Should have internal IP (port 80) sent to this internal IP, lets say 192.168.1.10)

With the wan port set to a static my internet doesnt work, when I set it to dhcp it works fine.

Here is my cisco config (set wan on dhcp for now) What changes do I need to make?

Using 1435 out of 196600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool CLIENTS
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
no ip address
!
interface Async1
no ip address
encapsulation slip
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 97.65.65.57
no ip http server
no ip http secure-server
!
!
ip nat inside source list 101 interface FastEthernet0 overload
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
login
!
end



See More: Static IP behind DHCP router

Report •


#1
October 5, 2011 at 11:17:35
"When I set the wan port to be one of my statics I cannot access the internet."

And when you asked your isp about this what did they say?

What possible help could we provide if its a isp provided ip? Did you enter all the entries correct like gateway and dns?

on the topic of forwarding to your web server I see no port forward to 192.168.1.10 per your example

Now on the other hand if you are trying to use that public

BTW your posts title doesn't match the message description. You are not trying to use public ip on your web server

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's


Report •
Related Solutions


Ask Question