Articles

Router booting in Rommon mode

September 6, 2007 at 04:16:11
Specs: Win XP, P4

Hi Folks,

I have a Cisco Router 1721. When ever i tried to switch on the router it automatically enters in to Rommon mode. Again i need to reload the router to get the router prompt (Enable mode)

Kindly let me know what is the actual cause of this problem.

Thanks in Advance

Asai


See More: Router booting in Rommon mode

Report •


#1
September 6, 2007 at 05:16:25

what the heak is rommon mode??
never ever seen that word before.
have you tried setting the router back to factory defaults?

Report •

#2
September 6, 2007 at 08:45:10

mountain

If you worked in cisco router you would have experienced this mode.

This is ROM Monitor mode which is used to change the reg entries to break router password. Below mentioned is the prompt symbol

rommon>


Thanks

Asai


Report •

#3
September 6, 2007 at 08:54:18

LOL - rommon mode is the mode you can go into to make certain changes should you screw up your configuration in such a way as to make it impossible to get back in. I've done this when the password gets messed up. I booted into rommon mode, made a change to a register which allowed me to reset the config to the factory default.

Anyhow, as far as I know, and I haven't done this for quite a while now......if you research on Cisco's site and on the web on your particular model, you should be able to find the information you need to reset to factory and boot normally.

Like I said, It's been a while since I've messed myself up and had to go into rommon mode to reset a switch/router so I can't say what change to make. That you'll have to research yourself.


Report •

Related Solutions

#4
September 6, 2007 at 09:08:30

Curt R

I need to know is there any possibility to prevent the router entering in to Rommon mode?

As far as i know we need to enter in to rommon mode for password breaking by pressing the break key.

By my concern is, Is there any problem in my router as it goes automatically in to rommon mode without pressing break key.

kindly help me...

Thanks

Asai


Report •

#5
September 6, 2007 at 10:45:29


There may be a hardware issue causing the problem. If however, someone changed a setting while it was in rommon mode, it might not be able to get back to booting normally until the setting is changed back.

The following link:
http://www.cisco.com/warp/public/474/pswdrec_2600.shtml
Is to a page on the Cisco site regarding a 2600 router (what I messed the password up on and had to reset to factory defaults in order to get back into the system....lol) that details how to enter rommon mode, what settings to change to reset it etc.

If you give it a quick read, it'll probably explain a few things. However, you will need to find such a sheet detailing what to do on the model you have.

If not a hardware issue, then it's entirely possible if you reset it to factory defaults and restore the most recent "good" configuration of your router, it will be back to working as it should. If someone accidentally made a change in the wrong register value it will keep going into rommon mode until it's changed back.


Report •

#6
September 7, 2007 at 17:03:02

Do a show version and see what the config register setting is set at , should be 0x2102 ,if not change it . Also do a dir flash: and see what code it is actually trying to load , if the router has a boot statement and it doesn't match what is in flash then it will go into rommon .


Report •


Ask Question