Articles

Renewing IP Address

Compaq/ Presario S6500NX
October 11, 2007 at 16:23:29
Specs: XP Home sp2, AMD Athlon XP 3000/1.0 GB

Hello, I am having a bit of trouble connecting my desktop to my college network. I have had a technician from IT come in and we determined that the signal is getting all the way to my computer (as in we used my cable with a device that would display an IP address assigned to it by the DHCP). The most frustrating part of this whole ordeal is that I did have a valid IP address that workd for a month--that is, until the internet security system of the campus wouldn't let me access any web sites. I was frustrated and called IT and they told me to /release and /renew using the ipconfig command. After doing so I lost my valid IP and haven't been able to get it back because it always comes up with the error "unable to connect to DHCP." As a result, I am assigned the lovely 169.254.xxx.xxx address. I have /flushdns, /registerdns, netsh int ip reset c:/log.txt, amongst many other things. I have updated the driver via a roommate's computer. I have uninstalled (using device manager) my network adapter and restarted the computer at which time it reinstalled itself. I have pinged 127.0.0.1 and there doesn't seem to be a problem (0% Lost). So on and so forth. I am trying to avoid taking my computer to Personal Computer Services because they do burn a hole in the pocketbook of a college student. In other words, I don't know what else to do. Does anyone have any advice to offer me hope?

Thanks


See More: Renewing IP Address

Report •


#1
October 11, 2007 at 16:46:21

Firewall ?

Or maybe the admins of the campus do work with mac address filtering.

Have you checked that?

Paul


Report •

#2
October 11, 2007 at 18:51:16

I don't think the firewall would do anything, it still doesn't work when I turn off Windows firewall. I don't know about the mac address filtering, I don't even know what it is. I can ask about that. The most difficult part for me to understand is that the network and internet have been working for a month, and then suddenly it is impossible to get an IP. I can call IT about the mac filtering. In the mean time is there any other things I can do before I take my tower to PCS?

Thanks for the help


Report •

#3
October 11, 2007 at 20:39:31

I would first try disabling and re-enabling your local area connection. If you are getting the "169.x..." address it means the DHCP isn't working. It usually indicates a bad cable (which you already tested), or bad network card.

The next step might be to manually assign an IP address. You don't HAVE to use DHCP, as it is just a service. You just need to ask the IT what network you are on. If this STILL doesn't work test another network card.

PS...I'll bet money they aren't using MAC filtering so don't worry about that.


Report •

Related Solutions

#4
October 11, 2007 at 21:04:16

Yeah, I tried disabling and re-enabling the connection. Unfortunately, that didn't work either. I asked about setting the IP address but as campus policy, they do not hand out static IPs. I suppose I could make one up based on my roommates, I will try that, but I have a feeling it won't work. I am afraid to admit that my NIC up and died on me, I suppose it could have, but it is part of the motherboard. I am using a VIA Rhine II Fast Ethernet Adapter, if that helps at all. I may take it into PCS tomorrow, if I can't get it working, but I don't know what they are going to do to fix it. I will ask them if they can install a temporary NIC and see if that works.

Thanks for the advice.

PS - I am still completely open to more suggestions, I really don't want to spend any more money trying to get this thing to work.


Report •

#5
October 12, 2007 at 06:33:31

You can test if your NIC is ok by pinging your loopback address. Open a command prompt window and type:

ping 127.0.0.1

Chances are since you get an APIPA address, there's nothing physically wrong with the NIC itself.

The 3'd thing it could be is a problem with the TCP/IP stack itself. You could try uninstalling then reinstalling TCP/IP.

If that doesn't work, your best bet is to call the college IT support people and ask them to give you a static IP so you can at least test and see if it will work with one.

Try all the above and report back.


Report •

#6
October 12, 2007 at 10:55:46

Sounds possible the winsock is hosed, or there is another firewall program running besides the windows firewall. If you have Norton, or Macafee, these usually have a firewall built in. Try disabling it (the firewall part) and see if you can do the renewing of your IP. If that does not work, try looking at this fix for winsock which may have been caused by a spyware removal tool:

http://www.tacktech.com/display.cfm...


Report •

#7
October 12, 2007 at 11:05:14

One more to confirm if Winsock is damaged:

http://support.microsoft.com/?kbid=...


Report •

#8
October 12, 2007 at 17:12:01

Well, it just so happens that I got the thing working again. Apparently, I used enough bandwidth to trigger a lock down on my computer for possible virus infestation. The network security people should have sent a notification to IT and they were to then ask me what was going on. But that message never made it so, PCS, IT and myself were all baffled as to what the problem was. I was able to get the IT supervisor to take a look and she found that I was on virus quarantine, and took me off. As a result, I can once again use my computer on the network. Thank you all for the help and advice. I really do appreciate it, it's just too bad that this all stemmed from a lack of communication between campus offices. But at least I know how to do a whole lot more stuff with if this kind of problem crops up elsewhere. Again, thank you all.

Report •


Ask Question