reinstalling network adapters

March 30, 2009 at 19:22:43
Specs: Windows XP, 1.8 GHz/256
So I can't connect to the internet. My pc was infested with vundo trojans. They were removed, but it did not restore the damage they did to my system When I checked my network adapters in the device manager, they were all listed with a yellow exclamation point. Also my network connections folder is empty. I tried making a new broadband connection with the new connections wizard, but it said it should be already configured and ready for use. Should I reinstall my network adapters? If so, how? Thank you,
Amy

See More: reinstalling network adapters

Report •


#1
March 30, 2009 at 21:09:43
Right click on the adapter in the device manager & click update driver. The drive should still be in the machine.

Report •

#2
March 30, 2009 at 21:18:59
Thanks for replying. I tried your advice already, but it only said " it could not find a better match for your hardware than the software you currently have."

I uninstalled the drivers and rebooted, but the computer said "it could not load the device driver for this hardware. It may be corrupted or missing."

I don't know what to do now.


Report •

#3
March 31, 2009 at 05:14:54
Download the driver on another PC, burn it to a CD and install it from there.

Report •

Related Solutions

#4
April 1, 2009 at 03:16:03
Yeah just download driver again and reinstall it. Might not fix it though as some viruses get really deep into the OS..

Report •

#5
April 1, 2009 at 15:09:55
Thanks guys. I tried looking for the drivers online, but I can't find the right ones for my pc. I tried my pc manufactor's site, but it didn't have it. So I might just bring it to a shop. Thanks for you help though.

Report •

#6
April 1, 2009 at 18:07:56
Buy a new network card with the software.

Report •

#7
April 2, 2009 at 07:07:11
Amy (by lain_is_cool)

list your motherboard name, maybe we can find your driver


Report •

#8
April 4, 2009 at 11:05:27
Hi,
My Pc is an Hp Pavilion a1102n
It has a 1394 net adaptor and a Realtek RTL8139/810x Family Fast Ethernet NIC
My family bought the pc in 2004.

I found drivers for the ethernet, but it didn't work.

Thanks guys.


Report •

#9
April 4, 2009 at 11:43:05
That'ss easy here is the driver selection page,

http://www.realtek.com.tw/downloads...


note that you will be picking the first option, IF you have windows xp or win 2000, if you have vista pick the 4th option. then click one of the 3 "go" buttons to start the download, i seem to remember the downloads from this site are painfully slow.


if this driver doesn't work come back and we will find another one, i seem to remember having problems with this one a good while ago, i might be mistaken though.


Report •

#10
April 4, 2009 at 17:56:43
I tried installing those drivers before and it didn't work. But I took your suggestion to use the auto install, and there was still no difference. Thanks for your help though.

Report •


Ask Question