Printing to shared printer does not work

April 23, 2010 at 01:20:23
Specs: Windows 7 Starter
I have a desk running Window XP Home, with a printer connected via a parallel port. I have a netbook running Windows 7 Starter. I've shared the printer and I can see it on the netbook. When I print from the XP machine it works fine. When I print to it from the Netbook, I get no error messages, but no output.

If I 'pause' the printer and print from the Netbook, I can see the print job in the queue (and it appears just like a print job from the XP machine), but when I take it off pause, the job disappears as if it has been printed, but I still get no printed output. I've checked HP for the latest drivers, tried uninstalling and reinstalling, all to no avail. I wonder if it is something to do with losing the fact that the printer is on LPT1, and it sends it 'nowhere', but I can’t fathom it out. Has anyone else experienced a similar problem?


See More: Printing to shared printer does not work

Report •


#1
April 23, 2010 at 05:44:14
I would disable the firewalls, just to see if it works. Then add exceptions if it does.

If Norton is running, bury that too.

Are you sure there are win 7 drivers for that printer?

How do you know when a politician is lying? His mouth is moving.


Report •

#2
April 23, 2010 at 07:04:11
How about starting with basic sharing? Can win7 access a shared folder on the xp box?

Are you logging into both with the same user account and password? If not do so.

Did you install the win7 print driver on the win7 box? If so go to properties and port. Is the port set to \\xpboxname\print share name?


Report •

#3
April 23, 2010 at 14:25:43
Thanks for your replies.
Normal file sharing was OK (yesterday), but playing up today - I think I need to get this resolved first. The printer settings on the Win 7 machine are all greyed out, but the printer says lpt1 on the Ports tab.

Report •

Related Solutions

#4
April 23, 2010 at 15:12:00
Sending the print job to the local port certainly isn't going to get it to the shared printer.

You need to make a new port as I described above and point the win7 printing to it.


Report •

#5
April 23, 2010 at 16:59:42
It sounds like you don't have admin rights on the win 7 box & wanderer is correct. LPT1 on the 7 box is worthless.

How do you know when a politician is lying? His mouth is moving.


Report •

#6
April 25, 2010 at 10:15:05
Thanks both for your help. I've now got it working. The print port set as you described did it. What I had actually done originally was install the printer on the netbook as a network printer. Win 7 "helpfully" even finds and lists my shared printer, and appears to complete, so I thought this was the right thing to do, but this didn't work.

What I did was install it as a local printer, and set the port as your describe. Thanks very much for solving my problem!


Report •


Ask Question