Articles

Port Forwarding Not Working

November 27, 2006 at 13:49:28
Specs: XP, core 2 duo/2 gigs

My computer is wired through a Linksys WRT54G router which I just reset last week. I usually play Warcraft III and in order to host I need to forward port 6112 to my IP. After I reset my router though, I cannot host even after forwarding it's port. I turned off my firewall, so I know that's not the problem and I have a static IP.

If this means anything, I also noticed that now when I type ipconfig in dos less information comes up, and it is blank after it says Connection-specific DNS suffix.

Any help would be greatly appriciated.


See More: Port Forwarding Not Working

Report •


#1
November 28, 2006 at 05:52:08

Hi there,

I don't think the lack of a Connection-specific DNS suffix is the cause of your problem here. This only comes into effect when your PC tries to resolve a hostname which is not fully qualified.

It looks like your port forwarding rule is using the correct port number ( 6112 ) , however, which protocol are you specifying on your port forwarding rule ( TCP / UDP / Both ? ) - it should be TCP.

One thing to check it to ensure you have enabled the rule once you have defined it to the router.

Presumably, normal internet connectivity works ok? ... just Warcraft hosting is a no-go?

If all this checks out, please can you paste in the output from an "ipconfig /all" ?

Cheers, Lofty.


Report •

#2
November 28, 2006 at 13:51:40

As far as protocol I was using both, but I tried it with TCP and it still didn't work. My internet seems to work fine except for Warcraft hosting.

Here is all of the info I got when typing in "ipconfig/all" in dos. (I may be wrong, but I think I recall there being more information before I reset my router):

Windows IP Configuration
Host Name.....................:Mike
Primary Dns Suffix............:(Blank)
Node Type.....................:Unknown
IP Routing Enabled............:No
WINS Proxy Enabled............:No
Ethernet adapter Local Area Connection
Connection-specific DNS Suffix:(Blank)
Description...................:Intel(R)82566DC Gigabit Network Conncetion
Physical Address..............:00-16-76-DB-80-3A
Dhcp Enabled:No
IP Address...................:192.168.1.125
Subnet Mask..................:255.255.255.0
Default Gateway..............:192.168.1.1
DNS Servers................:192.168.254.254

Thanks again for the help.

-Mike


Report •

#3
November 28, 2006 at 16:46:02

I noticed you mentioned this all happened since you reset your router - does this mean you managed to successfully host a Warcraft III game before?

Your IP configuration looks ok to me ... only thing I could see that looks a little strange is that your DNS server IP address ( 192.168.254.254 ) is set to a different IP address as your default gateway ( 192.168.1.1 ).

These settings don't necessarily have to match on your PC, however, if you're just using the linksys router and nothing else fancy ( like your own DNS server for example ) then usually the DNS server IP address should be the same as the router IP address, in your case 192.168.1.1. ( Your router acts as a DNS server - but all it does in fact is pass the DNS queries it gets from your local LAN onto the DNS servers it knows about - which were given to it when the router gets its DHCP lease from your ISP. ) .

You could try changing your DNS server setting in your IP configuration, however, given that you have already said that normal internet connectivity is fine - I don't think this is your problem.

Have you checked your the network configuration setting for Warcraft? ( Options -> Gameplay -> Game Port ). Perhaps it has another port number set there other than the default of 6112?

If that's still a no-go, try sticking your PC in the DMZ ( WRT54G's support DMZ I think ). However, BE CAREFUL! You *must* ensure that your PC's firewall is up and running ( although ensure it doesn't block TCP port 6112! ;o) ) along with ensuring your anti virus software if up too. Putting your PC in the DMZ is effectively the same as plugging your broadband modem directly into your PC.
Your PC will be unprotected by your router's firewall, therefore exposing it to all internet traffic - good and bad!

If it's still a no-go when your PC is in the DMZ, I don't think port-forwarding is your problem - perhaps it's a game config issue or worst case scenario, your ISP is blocking this type of traffic.

Good luck - let us know if you manage to get it sorted.

Cheers, Lofty.


Report •

Related Solutions

#4
November 29, 2006 at 12:31:39

I was able to host games before, and I just double checked to make sure that the port Warcraft is using is 6112.

I tried enabling DMZ but unfortunately was still unable to host.

Do you think I should contact my ISP and if so what exactly should I ask them?

Thanks again for all your help.

-Mike


Report •

#5
November 30, 2006 at 02:16:55

Hi Mike,

Hey - this is proving to be quite a challenge isn't it?! Ok - before you approach your ISP, I think we should try a couple more things here.

Let's take the router out of the equation totally - can you plug your broadband modem directly into your PC ( presumably via USB or ethernet port ) and see if you get any joy? Remember my warning above about ensuring your PC's firewall etc are enabled!

Another thing to check is to see if your PC is using a local hosts table - open up the following file in notepad -> "c:\windows\system32\drivers\etc\hosts", the only things in this file should be a load of comments, plus one hostname definition for local loopback, which should read -> "127.0.0.1 localhost loopback". If you find there are more hostnames in there, then take a copy of this file for safekeeping ( just in case! ) and remove all lines from it apart from the loopback definition.

If hosting works without your router, then I would be pretty certain the problem is with your router config or perhaps is a bug with the router firmware.

Check to see if you have any static routes coded on the router that you are unaware of that is affecting outbound traffic for Warcraft. This is unlikely ( as you would have had to put these routes in yourself ) but still possible.

Another possibility is that you might need to upgrade the router's firmware. Go to the linksys website for the latest firmware downloads ( make sure you download the correct firmware for your county and router version ).

If it's still a no-go with the modem directly connected to your PC, and you are *sure* that the game config is correct plus your PC's firewall trusts the Warcraft application in order for it to allow it to use the TCP/IP stack, then perhaps it's worth a quick call to your ISP's support team and explain that you are unable to host Warcraft III online games - ask them if they block certain types of inbound TCP traffic ( in this case TCP port 6112 ), tell them in detail what things we have gone through here.

Let us know how you get on.
Cheers, Lofty.


Report •

#6
November 30, 2006 at 16:19:42

I plugged my computer directly into my modem via ethernet cable, but I was unable to establish a connection. I tried going to Network Connections, then enabling Local Area Connection which didn't work. Then I also tried enabling 1394 Connection, which also didn't work. (I may be completely wrong about trying these to get connected to the internet, but I don't have an actual button to connect directly to my ISP, as the connection is usually already established.)

I checked my local hosts table which looks almost exactly like what you said, except mine only says "127.0.0.1 localhost", not "127.0.0.1 localhost loopback".

I do have the latest firmware upgrade for my router.

I'm just assuming that I'm doing something wrong in trying to connect to the internet directly through my modem.

Thanks again.

-Mike


Report •

#7
December 1, 2006 at 01:19:45

Hi Mike,

As you have a static IP address coded for your ethernet interface on your PC, you'll need to change it to DHCP when the modem is plugged in directly to your PC. This is because your PC will get a real internet address from the modem.

Write down the current settings you have for your PC ( actually they are listed above in this thread ) - and change the properties for TCP/IP for your ethernet interface to "Obtain an IP address automatically" and DNS should also be set to "Obtain DNS server address automatically".

Plug the modem directly into the ethernet interface and enable the ethernet interface under windows - you should find that you now have internet connectivity, if so - fire up Warcraft and see if that works.

Let us know what happens...
Cheers, Lofty.


Report •

#8
December 4, 2006 at 12:14:54

With the help you gave me I was able to connect to the internet perfectly, but I still cannot host. So it's either my computer or the ISP?

What do you recommend doing next?

Thanks again.

-Mike


Report •

#9
December 4, 2006 at 15:39:59

Hey Mike,

Ok - I think we can rule out your router in being the culprit here. So, yeah - it's either one of the following scenarios :-

1. Your PC's firewall is blocking the inbound traffic to TCP port 6112.

- or -

2. Your ISP is blocking this traffic before it gets to your PC.

Scenario 1 is the most likely here ( I'm 99% it's this as although still possible, I doubt your ISP would be blocking the traffic ).

Which firewall software is running on your PC? Is it the firewall that comes with Windows XP or are you using another firewall?

You need to check your firewall configuration to ensure that the main application filename for Warcraft ( ending in .exe ) has full permissions to send and receive to all IP hosts ( including the internet ).

You should be able to view your firewall log - most firewalls cut log entries when certain traffic is being blocked.

If changing your PC firewall configuration this way this fixes your problem, you should be able to revert your PC's IP address back to it's previous setting and plug your PC back into your router again.

I'm going to be off the net for a while ( moving home! ) but should be back in around 2 weeks.

Good luck!
Lofty.



Report •

#10
January 3, 2007 at 12:57:30

Ok I finally figured out what the problem was! It turns out my modem was not in bridge mode. Once I switched it to bridge mode by reseting it, and chaning my router to PPOE I was able to host perfectly. Thank you so much though for all your help and concern with my problem. And sorry for being so delayed with my response, but I didn't have much time with Christmas and everything. Anyway, thanks so much again.

-Mike


Report •


Ask Question