Solved PCs behind two hubs + router = no internet

August 18, 2011 at 04:00:40
Specs: Windows XP
DSL Modem <> Wifi Router <> 16port Switch<> 4 port Switch <> PC X&Y (via LAN)

(the 4port switch dan pc x&y are on 2nd floor, the rest 1st floor)

Wifi Router = Linksys WRT54GL (w/ tomato firmware)
16 port Hub = Netgear Prosafe 16 Port 10/100 Switch
4 port Hub = Linksys/Netgear, not sure, will confirm tomorow @ office

both PC X and PC Y can get ip address through DHCP, but cannot get internet access

PCs connected to Wifi Router or 16port Switch can get internet access..

Please help me solve this issue

See More: PCs behind two hubs + router = no internet

Report •

August 18, 2011 at 05:46:23
If you're connecting the two hubs with a patch cable, use a crossover cable. If you're using a crossover cable, use a patch cable.

How To Ask Questions The Smart Way

Report •

August 18, 2011 at 06:28:16
✔ Best Answer
lan port to lan port need a crossover cable unless either the switch or hub [not likely] support mdi/dmix

sounds like neither does so you need a xover cable

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •

August 19, 2011 at 02:22:08
Thanks for the replies..

So I changed the setup for 2nd floor PCs to this: (since it will take a while to find a crossover cable around here..)

DSL Modem <> Wifi Router <> 4 port Switch <> PC X&Y (via LAN)

4 port Hub = Linksys SD205, which has MDI/MDI-X detection

Now both PC X and PC Y can't get DHCP ip address (169.254.x.x)

What seems to be the problem?

edit: Solved, it's bad cable between Wifi Router and 4 port Switch, should've checked this earlier..

Report •

Related Solutions

Ask Question