Multiple Routers one gateway config

iphoneguy February 9, 2009 at 19:56:20
Specs: Windows Vista
I hate to ask what is probably a simple question, but after days of forum searching and hours upon hours of tweaking I still can't make this work.

I have a:
Dlink di-704 gatway with an ip:
Netgear WGT 624 Wireless router ip:
Linksys WRK 546 Wireless router ip:

Currently I am only using the Netgear wireless router, set up with a static IP address from my ISP, using one of the LAN ports for a Dell server which is for storage and set up for FTP use so I can remotely upload/download files.

I am wanting to use the Dlink as a gatway, connecting the Netgear/server for business use, and connecting the Linksys for a 'guest' wireless access point so clients can access the internet without seeing the Netgear/server.

Cable Modem
| |
Netgear Linksys

You name it, I've tried it, and I can't get it to work
The last thing I tried was setting up the Dlink with all of the correct static ip info, which worked because I can access the internet. I then turned off the DHCP on the Netgear and tried to change the LAN from to (the ip range the DLink gave me was from 100-199), but it didn't work. I can't even log back into the admin page of the Netgear using the have to reset it and start over. I've tried connecting LAN to WAN, LAN to LAN..nothing. Haven't even attempted the Linksys because I can't even get the Netgear to work lol.

Thanks in advance for any help! I truly appreciate it.

See More: Multiple Routers one gateway config

Report •

February 10, 2009 at 10:02:52
isp provided ip<wan>dlink<lan> <wan>netgear<lan> <wan>linksys<lan>

dhcp on for netgear and linksys to provide ips to their lan clients.

your ip addressing was wrong. you can't put the same subnet on each side of the router.

Report •

February 11, 2009 at 08:33:49
No dice.

Dlink works fine. Static Ip/gateway/subnet/and both dns all from isp. DHCP Enabled. WAN Subnet Mask, LAN IP:

Let's forget about the Linksys for now and make things simple.

In the basic settings, where it asks for the internet IP it gives two options, 'get dynamically from ISP', or 'Use Static'.

I chose 'Use Static' and per your post entered in:

IP Address:
IP Subnet:
Gateway IP Address:

I used the same DNS #'s provided by my ISP

On the LAN IP Setup I entered

IP Address:
IP Subnet Mask:
DHCP Enabled with an ip range of thru

There is a separate WAN setup page, but the only fields to enter an ip are if you check the Default DMZ Server.

I tried connecting from the Dlink LAN to the Netgear LAN, didn't work. I tried to the Netgear WAN as well..nope.

Report •

February 11, 2009 at 08:55:40
"IP Address:
IP Subnet:
Gateway IP Address:"

why would you put when the wan gateway is
how does it make sense to you to put the linksys wan ip in as gateway for the netgear?

Do you understand what a gateway entry is for?

Why didn't you setup as I diagrammed?

Report •

Related Solutions

February 11, 2009 at 09:14:01
The Linksys wasn't even hooked up at the time. I simply wanted to get the Dlink and Netgear up and running before attempting to add yet another router.

You'll have to excuse my ignorance, but no, I have no clue as to what the gateway entry is for. I didn't see in your diagram where you had specified a Gateway IP address. By entering the as the static IP, and the LAN as I thought I was following your diagram. Should the gateway IP address be the same as the LAN? I honestly dont' understand where I went wrong.

I do appreciate your time and assistance.

Report •

February 11, 2009 at 09:50:14
Not a problem.

A gateway is there as a "no one is answering on this subnet so let me shove the request out this door to see of someone out there responds"

The gateway entry for both and is the lan port of the dlink which is

So set the netgear wan port to
IP Address:
IP Subnet:
Gateway IP Address:

and the linksys wan port to:
So set the netgear wan port to
IP Address:
IP Subnet:
Gateway IP Address:

Report •

February 11, 2009 at 10:52:23
Freakin' Genius!! It works!

Thanks so much for your help, I truly appreciate you taking the time to share your knowledge. Hopefully this thread will help someone else out there as well!

Report •

February 13, 2009 at 09:44:29
Works like a charm, except for the FTP.
The server, which is connected to the NetGear, has an IP of

I log into the Dlink, and set up port forwarding: port 21 IP

I log into the Negear and set up port forwarding: port 21 IP

It's not working so obviously I've done something wrong...Inside the local network I can see the server, it's just when I attempt to FTP from outside that it doesn't work.

Report •

February 13, 2009 at 10:29:34
Have you ever ftp-ed to this server successfully before?

How about port 20?

Might consider just opening the ports in the netgear instead of forwarding them.

Report •

February 13, 2009 at 10:47:17
Yes, but that was when it was only one router. I didn't know if there was some trick now that everything is passing through the Dlink first.

I'll see if I can find where I can open the ports in the Netgear. I had it set to beginning port 20, ending port 21.

Report •

February 13, 2009 at 14:04:55
I rebooted everything and it works.

That said, does the way I set all of this up make the most sense? My thought process was having the Netgear/server completely separate from the Linksys guest feed would offer the most security.

Was there an easier way?

Thanks again for your help! I truly appreciate it.

Report •

February 16, 2009 at 13:11:56
If you had a managed switch that was vlan capable... that would have been easier. But given the equipment and criteria this is just fine.

Report •

Ask Question