Limited or No Connectivity! Please help :(

August 1, 2009 at 16:31:41
Specs: Windows XP
Hi! I've been trying to fix my connection for the past 24 hours nonstop. (The internet is really important to me) It's killing me! I am running on a router and I have Win XP. My router has 4 ethernet cables and they all work besides mines. I am on my mother's computer right now and I'm able to go online. I switched my hard drive with hers and plugged in her ethernet cable, and the internet still didn't work on my computer. However, it works on her computer which is how I am able to go online right now. So I'm assuming it has something to do with my computer since If it was my ethernet cable issue and not my computer, I would have been able to go online with her ethernet cable. My firework is also off.

I've tried downloading Winsock fix. It resetted everything etc but still did not work. I tried ipconfig reset & renew and it didn't work. I tried Repair Internet and It didn't work. I tried System Restore and It didn't work. I tried powering off my router etc. and it did not work. I tried resetting it and it did not work.

I did this (quoted from jack from another post)
Windows XP
Open up a command prompt (Start > Run > CMD)
Type the bolded commands in the command prompt window:

Reset TCP/IP Stack: netsh int ip reset reset.log
Reset WINSOCK entries: netsh winsock reset catalog

When finished reboot

Please post the results of the ipconfig /all command.

and my results were


See More: Limited or No Connectivity! Please help :(

Report •

August 1, 2009 at 16:45:24
The IPCONFIG result you posted, Was it obtained when your system was connected to the router"

Is it possible someone has configured the router to block your NIC's MAC address?

I have used that technique as a parental control method with my sometimes wayward offspring.

Have you looked in device manager to see if your NIC is working properly?
Is the NIC configured to "Obtain IP automatically" ?

The addrsss info in your ipconfig data doesn't look correct for a normal home based LAN. It looks like an external IP as supplied by your ISP

Goin' Fishin' (Some day)

Report •

August 1, 2009 at 18:41:51
Yes, I was connected to a router when I obtained the results. I don't know the possibilty if someone has configured my router to block your NIC's MAC address.. Wouldn't they need to know some private information or such? I don't know.

I checked my device manager and it is enabled and there is no red X or yellow ! It looks fine. Yes, my NIC is configured to Obtain IP automatically.

Any ideas what I should do? I'm stumbled. Usually I'm able to fix internet/hardware problems. However, this time I can't.

Report •

August 1, 2009 at 19:50:39
Can you log into the router admin interface and check the LAN settings ? Do this from one of the working PCs on the LAN What IP range is enabled and is there any MAC filtering enabled?

Goin' Fishin' (Some day)

Report •

Related Solutions

August 1, 2009 at 21:11:52
Can you tell me how to do that? I only knew how to do that with my Linksys router that stopped working a few days ago. We have a backup router that I'm using now but it's not a brand name router. I don't know the router IP addy either.

Report •

August 2, 2009 at 00:33:49
From each working PC in the LAN, run IPCONFIG command and check the listings for gateway and DNS server.
The Gateways should all be identical and that is the Router IP.
Try entering that IP in a browser and see where it takes you

If you are lucky the password will be either blank or you will at least identify the make/model

Goin' Fishin' (Some day)

Report •

August 2, 2009 at 20:08:21
I finally got it to work somehow. I uninstalled & reinstalled my network drivers again. I did it before but it didn't work. I think maybe cause I uninstalled something more or installed + restarted my computer again? I'm not sure but it works now :) Thanks for your help.

Report •

Ask Question