Solved Issues with VLANS with Cisco 2611 and DDWRT Switch Setup

Lenovo / 7269d2u
December 30, 2011 at 10:10:09
Specs: Linux i686), 2.659 GHz / 3071 MB
Hello, hopefully someone can help me out with this, I have been struggling for days now. Basically, I purchased a Cisco 2611 router running IOS 12.3(26) with the more advanced feature set including 802.1q and some other cool features. I am training up for my CCNA and figured it would be a good idea to get some hands on practice.

Besides being a learning experience, I actually want to use the router for my Internet connection. I have a cable modem which hooks into WAN port (ETH 0/0) on the Cisco then to a Linksys wrt54gl router running DDWRT setup as a switch with DHCP disabled.

Everything works fine, besides having to run in half-duplex mode since the 2611 dosen't support auto-negotiate and the Linksys and cable modem drop down to 10mb half duplex. I am OK with this as I only have 5 computers on the network anyway so it isn't too much of a performance decrease.

Anyway, what I am trying to do is setup two VLAN interfaces in the Cisco and then setup VLAN tagging in the DDWRT switch to allow two separate VLANS On my network. One will be fore my home computers and the other will be for my web server. I have setup the interfaces in the Cisco already, but am having some trouble understanding how the VLANS work with the DDWRT device.

I have the two VLANS on different subnets than the actual interface of eth 0/1. I am assuming I need to setup DHCP pools for each VLAN subnet as well? Can anyone please help me with the VLAN tagging in the DDWRT device?

Here is my config file from the 2611 router:

Router_2611#sh run
Building configuration...

Current configuration : 1923 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_2611
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip domain name 2611
ip dhcp excluded-address 192.168.1.100
ip dhcp excluded-address 192.168.1.104
--More-- ip dhcp excluded-address 192.168.1.110
ip dhcp excluded-address 192.168.1.101
ip dhcp excluded-address 192.168.1.102
ip dhcp excluded-address 192.168.1.103
ip dhcp excluded-address 192.168.1.105
ip dhcp excluded-address 192.168.1.106
ip dhcp excluded-address 192.168.1.107
ip dhcp excluded-address 192.168.1.108
ip dhcp excluded-address 192.168.1.109
!
ip dhcp pool LAN_DHCP_POOL
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server xxxxx xxxxxxxx xxxxxxxxx
!
ip audit po max-events 100
!
!
!
!
!
!
!
--More-- !
!
!
!
!
username minorix46 password 0 xxxxxxxxxx
!
!
ip ssh port 9000 rotary 1
!
!
!
!
!
interface Ethernet0/0
description This is facing the ISP (WAN)
ip address dhcp
ip nat outside
half-duplex
!
interface Serial0/0
no ip address
shutdown
--More-- !
interface BRI0/0
no ip address
encapsulation hdlc
shutdown
!
interface Ethernet0/1
description LAN Interface
ip address 192.168.1.1 255.255.255.0
ip nat inside
half-duplex
!
interface Ethernet0/1.1
encapsulation dot1Q 10
ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/1.2
encapsulation dot1Q 15
ip address 192.168.3.1 255.255.255.0
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static tcp xxxx 80 interface Ethernet0/0 80
no ip http server
--More-- no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
!
line con 0
password xxxxxxxxxx
login
speed 115200
line aux 0

!
--More-- !
end

Router_2611#


See More: Issues with VLANS with Cisco 2611 and DDWRT Switch Setup

Report •


#1
December 31, 2011 at 05:14:09
✔ Best Answer
Can anyone please help me with the VLAN tagging in the DDWRT device?

Highly unlikely I'm sorry to say.

If you're using DD-WRT on a device that means it's a SOHO router (make/model would have been excellent info to include) which means you can't run multiple VLAN's.

At least, I've never seen a VLAN capable SOHO device that was capable of having more than one VLAN. In my experience, you can't assign VLAN's to individual ports on a SOHO device. On VLAN capable devices you can assign a single VLAN which is by default applied to all ports.

Check around and see if you can't get your hands on an older (cheaper) L2 or L3 switch somewhere. If you're in Canada and are willing to pay the shipping I might be able to get you a deal on an older Cisco 2900XL 24 port switch. If you're not in Canada just google "buy older used Cisco equipment" and you should find some places to purchase older (used) equipment.

Oh and IMHO, and this is my opinion only, DD-WRT sucks. My preference is Tomato. Someone put DD-WRT on a Linksys WRT54GL and I couldn't get it off. The sneaky DD-WRT folks don't want you changing your mind once you've installed their firmware and in my books that's just wrong. I find Tomato overall is a better firmware and if I want to change my mind about using it, I can.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#2
December 31, 2011 at 14:41:17
I have actually solved my problem. The router I have is a WRT54GL Linksys. DDWRT allows you to setup VLAN tagging and port/VLAN assignments. The WRT54GL is one of many SOHO devices that support VLANs. The way the VLANs are setup in the GUI interface is a bit odd compared to Cisco switches, but I figured it out and it works great.

Thanks for your help.


Report •

Related Solutions


Ask Question