Help! Wrong IP?

Compaq
January 30, 2007 at 20:58:55
Specs: Windows XP, Intel, 512mb
Thanks for your time.. this is the problem;

I've got 2 computers; both XP machines running into a D-Link router using ethernet. One machine works fine, but the other can't connect to the internet nor the local network.

(The ethernet card and cable both have been checked and work fine).

The IP address assigned to the faulty computer has completely the wrong range and subnet (instead of being 192.168.1.xxx it is 169.xxx.xxx.xxx) when automatically assigned. I think that solving this will solve the connection problems.

The problem is not solved however when I uncheck "automatically detect settings" and change to a static local IP address of the right form in the TCP/IP settings in the local area connection.

I also can't connect to the web interface of the D-Link router, the other (working) computer does this fine when i type 192.168.1.1 in my browser.

Any ideas on how to get the computer connected?


See More: Help! Wrong IP?

Report •


#1
January 31, 2007 at 01:05:14
You are getting an address from the router so the pc assigns a microsoft default address of 169.x.x.x . Make sure your nic is set for dhcp . Also check the simple stuff like do you have a link light on the router and on the nic card itself . If you manually put in a 192.168.1.x address and you can't ping the router its a physical problem or the nic is noi good . Check in your system settings and make sure the card looks like it is working normally.

Report •

#2
January 31, 2007 at 01:56:10
Yea, you cannot get on the internet because you don't have an ip address handed out from your router.

statically assign the broken computer an ip address 192.168.1.200 subnet mask 255.255.255.0
gateway 192.168.1.1
dns server 192.168.1.1

by right clicking the network card in network connections and going to properties, and click on ip protocol tcp/ip
set to manually whatever

then goto start run and type cmd hit enter
Type ipconfig /all (hit enter)
and makes sure you only have the ip address 192.168.1.200 and no other nic is enabled going to the dlink, Disable all other nics and wireless if you have any through network connections by right clicking the adapters and selecting disable.
Leaving only the wired connection to the dlink enabled which should be the local area connection but doesn't have to be, especially if you reinstalled the driver over and over again.
type in the dos window where you typed ipconfig /all
ping -t 192.168.1.1 (hit enter)
Leave running through whole troubleshooting process ctrl c to stop
If you get a reply but some are dropped most likely cable or port on router,
if you don't get a reply make sure you have a link light, little light on the nic card, back of broken computer, usually green, and on the dlink where broken computer is plugged in and see if it's on, link enabled etc, plug the cable into another port on dlink, if ping still doesn't show you packet or replys replace the cat 5 cable, Move the broke machine to where the working one is and use it's cable and see if it works.still not fixed, swap the nic in the broken computer with the good one from the other machine, still not fixed,
google reinstalling tcp/ip in XP. Using netsh int etc never works,so avoid it for this issue
Your going to have to get your hands dirty with manually removing reinstalling tcp/ip. u might just want to use another option by booting off the xp cd by inserting the disk and tell it to do an install.
say something like install xp on first question screen, and do not select repair from recovery console. Then select reinstall on the next question, takes about 5-10 mins to get to that point. On a new computer takes 40 mins to do the whole reinstall process and can fix some major issues, because it pretty much delete the windows folder after backing up the registry. Reinstalling it, and importing your settings. The machine will then only have the same service packs and updates as the cd so do the windows update and soon as you can, but all of your data will be there.

btw, the 169.X.X.X ip you listed in the post is a feature of windows when it doesn't see a dhcp server, router or machine which hands out ip addresses, and doesn't have statically assigned ip address like 192.168.1.200.

Please post type of network cards, XP Version , the results of ipconfig /all, and we should be able to help you. You can also test your card by downloading and burning a Linux Live Cd or Bart's Windows Boot Cd, google. Boot off the disk and goto the cmd from run again, and try to ping your router, 192.168.1.1
if you can it's definitely a tcp/ip problem.

if you forgot to say this is new install in your post and none of steps worked, either your dhcp server on dlink is turned off, or face it the nic in that machine is fried.


I spent a lot of time writing this out, even though it doesn't flow too nice; it's very late where im at, and it would have much quicker to actually just done the procedure, so please respond with the results so other people can benefit.


95% of all computer techs don't know crap, and 99.5% of computer techs think they know everything.


Report •

#3
February 7, 2007 at 05:54:05
I am having a similar problem, only with a wireless connection. The connection was working fine until about a week ago when I tried to install Zone Alarm Pro, and then everything stopped. I uninstalled ZA, disabled the firewall and I still get the APIPA address. I found a way to stop the APIPA address assignment (editing the registry), and now instead of the 169.X.X.X address, I get 0.0.0.0 - so no address at all. I know the wireless router's DHCP works because I can bring in my laptop from work and it gets assigned a proper address and connects.

I have tried assigning a fixed address that is within the subnet and both within and outside the set of addresses that the router can freely assign. When I do this, I can ping the router and the other machines on the network (my work laptop, an iBook laptop, a desktop that is wired to the router, and a networked printer all respond to the ping), but I cannot access the internet, nor can I print to the networked printer.

As for the statistics, the machine is a home built 1.9GHz P4 running XP, SP2 with 1G memory. The wireless nic card is a Linksys G card (PCI - I don't recall the model number), and the router is a Linksys WRT54GL. BTW, I also tried this with a Linksys USB 802.11B connector that I borrowed from a neighbor and got the same results - no IP address assigned. I am convinced that there must be some setting that the computer is not accepting an address from the router's DHCP server...


Report •

Related Solutions


Ask Question