D-LINK DIR-615 issue with FTP and W

D-link / Dir-615
April 12, 2009 at 10:33:53
Specs: Windows XP SP-3

I just replaced my Netgear WGR614 router with a D-LINK DIR-615, and I'm having some problems. Previously I've had my webserver running Apache on port 80 with no problem, and also a FTP at port 21.

With this new router I opened the ports (80 and 21) in the UI, and it seemed to work just fine. However, when I try to access my webserver in the browser from the external ip it takes several minutes to load, and javascripts and such does not even work. If I use the browser and the internal ip, it loads up right away just fine.

The same issue is with my FTP server - you can connect fine, but when you try to download something, the dl speed is below 500 b/s, and it drops until you get disconnected. When I connect with the internal ip, really fast.

So I'm really confused what to try next. The ports are open, you can access it just fine - it just takes forever to load anything. I've tried different ports, but same story. I also have the latest firmware. I don't know if I have missed any settings in the UI, but I really can't think of what. The weird thing is that uTorrent can download stuff in several mb/s with no problem whatsoever.

So if you have any ideas, please help me out. Really frustrating stuff.

See More: D-LINK DIR-615 issue with FTP and W

Report •

April 12, 2009 at 11:17:43
are you inside the lan when trying to access via external ip?

Report •

April 12, 2009 at 11:34:56
I have tried both ways.

Report •

Related Solutions

Ask Question