Configure 2 routers to use PPP

April 12, 2010 at 14:14:16
Specs: Packet tracer
Hi
I am new to this forum so not sure if anyone might be able to help me out.

I have the following setup in packet tracer: pc1, router1, router2, pc2.

I have set up the following configuration on the routers:

router1 (fa 192.168.16.1)
router1(config)#interface serial 2/0
router1(config-if)#ip address 192.168.15.1 255.255.255.0
router1(config-if)#clockrate 64000
router1(config-if)#no shutdown
router1(config-if)#exit

router2 (fa 192.168.16.2)
router2(config)#interface serial 0
router2(config-if)#ip address 192.168.15.2 255.255.255.0
router2(config-if)#no shutdown
router2(config-if)#exit

I now need to configure ospf on each router but this is where I am confused.

Am I right in thinking that ospf should be configured as follows for router 1?

Router1(config)# Router ospf 100
Router1(config-router)# network “192.168.16.0” “0.0.0.255” area 0
Router1(config)#exit

Any help / advice would be appreciated.

Thanks



See More: Configure 2 routers to use PPP

Report •


#1
April 12, 2010 at 16:59:23
The syntax is correct for advertising the ethernet network but with osfp you also need to advertise all connected networks. You will need to add your serial network too. This will have to be done on both of your routers.

Report •

#2
April 15, 2010 at 12:58:42
Hi there
thanks for getting back to me. I have set up the following on each router as you advised.

router1(config)#router ospf 100
router1(config-router)#network 192.168.1.0 0.0.0.255 area 0
router1(config-router)#network 192.168.15.0 0.0.0.255 area 0
router1(config-router)#exit

router2(config)#router ospf 100
router2(config-router)#network 192.168.15.0 0.0.0.255 area 0
router2(config-router)#network 192.168.0.0 0.0.0.255 area 0
router2(config-router)#exit

I can ping from pc 1 to router 1 and I can also ping from pc 2 to router 2. but i cannot ping from pc1 to router 2 it fails. I have tried pinging router 1 to router 2 and that also fails.

I am not sure if i mentioned earlier I have built this in packet tracer. Please can anyone give me some advice on trouble shooting this?

thanks


Report •

#3
April 16, 2010 at 04:10:53
Its been a while since I studied cisco so correct me if i am wrong.

When you use the "0.0.0.255" wild-card mask - you are instructing the router to either check or ignore octets in the address match the criteria.
For example
0(check) . 0 (check) . 0 (check ) . 255(ignore)

With your subnets, the router will perform the following :-

192(check) . 168(check) . 1(check) . 0(ignore)
192(check) . 168(check) . 15(check) . 0(ignore.)

Because you are using a /24 mask with 2 different subnets (168.15.x and 168.1.x) you are in effect blocking the 168.15.x and the 168.1.x networks from speaking to each other.

Your wild-card mask should read 0.0.255.255

192(check) . 168(check) . 1(ignore) . 0(ignore)
192(check) . 168(check) . 15(ignore) . 0(ignore.)

router1(config)#router ospf 100
router1(config-router)#network 192.168.1.0 0.0.255.255 area 0
router1(config-router)#network 192.168.15.0 0.0.255.255 area 0
router1(config-router)#exit

router2(config)#router ospf 100
router2(config-router)#network 192.168.15.0 0.0.255.255 area 0
router2(config-router)#network 192.168.0.0 0.0.255.255 area 0
router2(config-router)#exit

Gigabyte GA-965P-DS3P
Intel Core 2 Duo E6420
2x1Gb Corsair XMS2 DDR2-800Mhz
Sapphire x1950Pro
500GB Cavier Blue
500W FSP Bluestorm PSU


Report •

Related Solutions

#4
April 16, 2010 at 06:02:02
Hi thanks for getting back to me on this.

I have set up the following as you advised but I still can't ping from router 1 to router 2?

when I do show ip route on router 1 it shows:

router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet0/0

and router 2:

router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.0.0/24 is directly connected, FastEthernet0/0

Is this correct?

Thanks


Report •

#5
April 18, 2010 at 01:37:11
" C 192.168.0.0/24 is directly connected, FastEthernet0/0"

Can you clarify where this subnet has come from? it is not a valid address.

It looks as if there has been an error in the posts with your IP address scheme.

It should read:-
router1 (fa 192.168.16.1)
router1(config)#interface serial 2/0
router1(config-if)#ip address 192.168.15.1 255.255.255.0
router1(config-if)#clockrate 64000
router1(config-if)#no shutdown
router1(config-if)#exit

router2 (fa 192.168.16.2)
router2(config)#interface serial 0
router2(config-if)#ip address 192.168.15.2 255.255.255.0
router2(config-if)#no shutdown
router2(config-if)#exit

router1(config)#router ospf 100
router1(config-router)#network 192.168.15.0 0.0.255.255 area 0
router1(config-router)#network 192.168.16.0 0.0.255.255 area 0
router1(config-router)#exit

router2(config)#router ospf 100
router2(config-router)#network 192.168.15.0 0.0.255.255 area 0
router2(config-router)#network 192.168.16.0 0.0.255.255 area 0
router2(config-router)#exit


Appologies for the typo with the IP address range.

Gigabyte GA-965P-DS3P
Intel Core 2 Duo E6420
2x1Gb Corsair XMS2 DDR2-800Mhz
Sapphire x1950Pro
500GB Cavier Blue
500W FSP Bluestorm PSU


Report •


Ask Question