Cisco router no internet access

November 24, 2012 at 11:42:35
Specs: Windows 7, I3/4GB

BELOW IS THE RUNNING CONF.

Router#sh run
Building configuration...

Current configuration : 1242 bytes
!
! Last configuration change at 18:45:13 UTC Sat Nov 24 2012
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
!
!
!
ip dhcp pool TheRoyalSenchi
network 192.168.23.0 255.255.255.0
dns-server 80.87.78.11 80.87.78.4
default-router 192.168.23.1
!
!
ip cef
multilink bundle-name authenticated
!
!
license udi pid CISCO1841 sn FHK142470ZM
username Godwin privilege 15 secret 5 $1$rJve$dKdCdydcJc84h9mwOBIop1
!
!
!
!
!
!
interface FastEthernet0/0
description LINK TO VODAFONE GHANA
ip address 44.77.241.254 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description THE ROYAL SENCHI INTERNAL LAN
ip address 192.168.23.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip nat inside source list 10 interface FastEthernet0/0 overload
ip default-network 192.168.23.0
ip route 0.0.0.0 0.0.0.0 44.77.241.253
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end


See More: Cisco router no internet access

Report •


#1
November 24, 2012 at 16:03:01

Are you trying to add a router in a hotel where one already exits?

How do you know when a politician is lying? His mouth is moving.


Report •

#2
November 25, 2012 at 05:51:45

The following catches my eye:

ip dhcp pool TheRoyalSenchi
network 192.168.23.0 255.255.255.0
dns-server 80.87.78.11 80.87.78.4
default-router 192.168.23.1

The DNS servers are in a completely different network and unless I missed something, I see no route to that network. No route to the DNS network means no DNS resolution which in turn means no internet.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#3
November 26, 2012 at 00:32:55

this is the only router we are trying to use....when i use
44.77.241.254 255.255.255.252 44.77.241.253 in my dlink router everything works fine

Report •

Related Solutions

#4
November 26, 2012 at 00:34:51

@Curt R, this the same dns server i use in my dlink router and it works fine

Report •

#5
November 26, 2012 at 07:14:58

Okay, but I wager your dlink router has a route to that network.

While not familiar with that exact model of Cisco product, the config file isn't a whole lot different than the ones I'm used to working with and I will repeate once, and only once:

I see no route from the 192.168.23.0/24 network to the DNS network (ie: 80.87.78.xxx)

Perhaps nobody has mentioned it to you but, you need a route between separate networks in order for them to communicate. Now, I just went throughh you config a second time and nowhere in it do I see mention of the 80.87.78.xxx network except in the DNS entry.

You've provided a DNS entry, but since it's a completely different network, there's no way to reach it. You need to be physically connected to that network, and have an entry in your routing table going from 192.168.23.0/24 to 80.87.78.xxx or the DNS requests will never reach a DNS server and be resolved which equals no internet.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#6
November 26, 2012 at 08:34:17

Curt R,
Looking at the my conf setup can you provide me with the commands to do that because am confused right now......Thank you in advance

Report •

#7
November 26, 2012 at 09:38:07

Actually, no, I can't.

I'd have to be sitting at the console and I'd have to muck around to figure it out. We've gone away from Cisco products where I work (thank goodness!) and it's been a couple years since I worked on one. Also, I've never played with their routers too much.

I would suggest you:
1) backup the configuration to a flash memory or onto a PC before doing anything else
2) Read the manual
3) Get signed up on the Cisco forums and search there for help

The third one is real important. They are forums like this one but it's where cisco guru's hang out so you'll get much better help, and advice there than I could hope to give you. Search something like "cisco help forum" to find a place. There are a few. You shouldn't have to pay anything but you will have to sign up on a forum and become a member in order to ask a question. Again, it's been a while for me but that's what I used to do whenever I had a cisco related question.

Just remember, in any Cisco CLI I've worked with, you can get help on comands by putting a question mark after the command. For example, help on the configuration command would be as follows:

config ?

(NOTE: you don't have to use the whole command word, just 4 or 5 characters will do for the longer ones. Also, in my above example, you could hit the "Tab" key after typing in "config" and it would autocomplete the rest of the word (ie: configuration) )

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#8
November 26, 2012 at 11:19:57

thank you CURT R....

Report •


Ask Question