Articles

Cisco 2960 switch configuration

Catalyst 2960
December 2, 2008 at 22:39:17
Specs: NA, NA

I have 3 Catalyst 3560 24 port switches that are daisy-chained through standard 10/100 ports using straight through Cat5e cables. I'm not using the SFP connectors or crossover cables. I'm trying to add a 24-port Catalyst 2960 to the network. I get through the Express Setup just fine... and I can connect the new switch to the network (using a straight through cable). I can even access the switch's built-in interface via a web browser and verify the port status and configuration.

The problem occurs when I connect any computers to the 2960's ports... the first port linking back to the 3560 errors out every time and disables. The computer never has a chance to get an IP from our DHCP server, and the switch is unreachable again until I disconnect all ports and wait for the error to clear. I've tried using a crossover cable between the 2960 & 3650, tried various ports on both switches, checked the config on the existing 3650s, etc. I'm not very good with Cisco, so I'd like to solve this through the web interface, but I'm open to any suggestions. I just need to get the new switch up and running ASAP.
Thanks!


See More: Cisco 2960 switch configuration

Report •


#1
December 3, 2008 at 07:36:10

You do of course realize that daisy chaining switches is a bad idea right?

Also, it's always best to use a crossover when connecting like devices. I know most, if not all, modern switches are MDIX capable, but, using crossover cables rules out one issue should any problems arise and you find yourself troubleshooting. It's a "best practice" thing one should always keep in mind.

The problem occurs when I connect any computers to the 2960's ports... the first port linking back to the 3560 errors out every time and disables.

I'd wager you're trying to daisy chain that 2960 to #3 switch on the present chain. Stop it! What you really need to do is cascade the switches together. If you don't have a backbone and can't connect the switches singly you really REALLY need to cascade them. This would in effect convert 3 separate (but daisy chained) switches into a single unit (ie: one big switch). This is a lot more effective in regard to resource allocation and bandwidth usage, and, it eliminates the bandwidth overload a daisy chain creates.

This sounds almost like a loop. Are you using STP and/or CDP? Do you have anything else plugged in to the new switch or just a single daisy chain link?

The way I see it, the issue is one of three things:
1) Hardware issue
2) Configuration issue
3) Too many switches daisy chained together

I guess to be able to help you we'll need to have a look at the configuration on the working switches and compare it to the one that isn't working.


Report •

#2
December 3, 2008 at 12:23:42

Thanks for the suggestions. It turns out I was mistaken on the switch configuration. The 3 switches were cascaded and using STP, and I was connecting the 2960 to a switch other than the root bridge. Once I connected to the proper switch everything worked fine.
Thanks for the solution!

Report •

#3
December 3, 2008 at 13:11:11

I'm glad I could help you figure out what was going on. :)

Report •

Related Solutions


Ask Question