Cisco 1720 Router Configuration

June 10, 2009 at 11:57:44
Specs: Windows XP
I have 2 Cisco 1720's that I need to connect the 2 routers via crossover for testing. I haven't touched a cisco router in years!

Help...


See More: Cisco 1720 Router Configuration

Report •


#1
June 10, 2009 at 12:19:36
Might want to visit Cisco's site.

Report •

#2
June 11, 2009 at 05:58:47
It would help if you could elaborate a little more on what kinda help you need with those routers.
If you just want to connect them using a crossover cable, configure the ethernet interface of each router with an IP address in the same subnet e.g. 192.168.1.1 & 192.168.1.2.
I'm assuming that you know how to connect your PC to a router using a console cable.

Commands:
-----------------
User Access Verification

Password: 'Enter the password, if there is one set.'

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastEthernet 0/0 'The interface number may be different on your router e.g. 0/1. You can always use ? while typing the command to get help.'
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
-----------------

Use the same commands on the second router - just change the IP address to 192.168.1.2.


Report •

#3
June 11, 2009 at 10:27:37
Thanks for the help! I think i have the ip info correct, because now i can connect to each router via ethernet . Here is the big plan for these 2 routers. I am testing latency across a 4.9 Gig wireless network. the network diagram is:

PC - Cisco 1720 (Eth port) - T1 to Eth converter (T1 DSU/CSU port) - Wireless node (Eth port on the converter) - Wireless node at 2nd location - then the B side is just like the A.

Does that make sence at all??

So I can talk to Cisco A with an ip of 192.168.1.165 via Eth. I have a crossover from Cisco A to Cisco B in the T1 port. I cannot talk to Cisco B currently.


Report •

Related Solutions

#4
June 11, 2009 at 10:30:40
Also... here is the current config:

sho run
Building configuration...

Current configuration : 722 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$6/gF$YxrbBVt2qjQszF7qo/iWP.
enable password dci4611
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
no ip routing
!
!
--More--  !
!
interface Serial0
no ip address
no ip route-cache
shutdown
no fair-queue
!
interface FastEthernet0
ip address 192.168.1.165 255.255.255.0
no ip route-cache
speed auto
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.170
no ip http server
!
access-list 101 permit ip any any
snmp-server community public RO
!
line con 0
line aux 0
--More--  line vty 0 4
password dci4611
login
!
no scheduler allocate
end


Report •

#5
June 11, 2009 at 13:02:41
I'm sorry but your description of the diagram is not easy to comprehend. What I get from that is you have a PC connected to the ethernet port of your router (let's call it Router-1). Router-1 then connects to a wireless node through a converter. Now this wireless node is obviously wirelessly connected to the second wireless node connected to Router-2.

"So I can talk to Cisco A with an ip of 192.168.1.165 via Eth. I have a crossover from Cisco A to Cisco B in the T1 port. I cannot talk to Cisco B currently."

You have the two routers connected through a crossover cable? Your description fo the diagram tells me that they're wirelessly connected. This is confusing. Some explanation would really help.
What's the configuration on Router-2, and what type of devices are those wireless nodes that you're using?


Report •

#6
June 11, 2009 at 13:28:57
I'm sorry, I know this is quite confusing. We wont worry about the wireless portion right now... My current status is:

PC1 connected to Router 1 via ethernet
Router 1 connected to Router 2 via crossover

Router 2 connected to PC 2 via ethernet.

PC 1 is running hyperterminal talking to Router 1

From hyperterm i can ping the Serial0 of Router 2, but i cannot ping the Fastethernet0 IP address, and i cannot ping PC 2 either.

Router 1 Config:

sho run
Building configuration...

Current configuration : 722 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$6/gF$YxrbBVt2qjQszF7qo/iWP.
enable password dci4611
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
no ip routing
!
!
--More--  !
!
interface Serial0
no ip address
no ip route-cache
shutdown
no fair-queue
!
interface FastEthernet0
ip address 192.168.1.165 255.255.255.0
no ip route-cache
speed auto
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.170
no ip http server
!
access-list 101 permit ip any any
snmp-server community public RO
!
line con 0
line aux 0
--More--  line vty 0 4
password dci4611
login
!
no scheduler allocate
end

Router#sho run
Building configuration...

Current configuration : 727 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$6/gF$YxrbBVt2qjQszF7qo/iWP.
enable password dci4611
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
no ip routing
!
!
--More--  !
!
interface Serial0
ip address 1.1.1.1 255.255.255.252
no ip route-cache
no fair-queue
!
interface FastEthernet0
ip address 192.168.1.165 255.255.255.0
no ip route-cache
speed auto
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
!
access-list 101 permit ip any any
snmp-server community public RO
!
line con 0
line aux 0
line vty 0 4
--More--   password dci4611
login
!
no scheduler allocate
end

Router 2 Config:

sho run
Building configuration...

Current configuration : 755 bytes
!
version 12.1
service config
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$OjGy$KC/GXfXJx5pUOu20jS6hK1
enable password dci4611
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
no ip routing
!
--More--  !
!
!
interface Serial0
no ip address
no ip route-cache
shutdown
!
interface FastEthernet0
ip address 192.168.1.170 255.255.255.0
no ip route-cache
speed auto
half-duplex
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.165
no ip http server
!
access-list 101 permit ip any any
snmp-server community public RO
!
line con 0
--More--   exec-timeout 0 0
line aux 0
line vty 0 4
password dci4611
login
!
no scheduler allocate
end

Router#sho run
Building configuration...

Current configuration : 727 bytes
!
version 12.1
service config
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$OjGy$KC/GXfXJx5pUOu20jS6hK1
enable password dci4611
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
no ip routing
!
--More--  !
!
!
interface Serial0
ip address 1.1.1.2 255.255.255.252
no ip route-cache
!
interface FastEthernet0
ip address 192.168.1.170 255.255.255.0
no ip route-cache
speed auto
half-duplex
no cdp enable
!
ip classless
no ip http server
!
access-list 101 permit ip any any
snmp-server community public RO
!
line con 0
exec-timeout 0 0
line aux 0
--More--  line vty 0 4
password dci4611
login
!
no scheduler allocate
end

Also, ic case you were concerned about me not blocking out the ip info... these routers will never be on a network so there is no worry of hacking.

Thanks a bunch for your help so far, I really appresiate it.


Report •

#7
June 11, 2009 at 15:20:58
Alright.. first of all backup these configurations. Just like you've done here, copy and paste them in notepad and save the file.
Now delete the configurations on both routers by using the commands:
------------------------
Router#erase startup-config 'On some routers it's Router#delete startup-config'
Router#reload
------------------------
Now the router may come up with a message that the configuration has been changed and if you want to save it - choose NO. If it asks to proceed, choose YES.
After the router boots again, it's going to ask you if you want to enter the initial configuration dialog - choose NO.

Now type in these commands:
------------------------
Router>enable
Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#ip address 1.1.1.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0
Router(config-if)#ip address 192.168.1.165 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 1.0.0.0
Router(config-router)#network 192.168.1.0
Router(config-router)#exit
Router(config)#exit
Router#write
------------------------

Use the same commands for Router-2, except for the ones in bold. Use these commands in their place:
------------------------
Router(config-if)#ip address 1.1.1.2 255.255.255.252

Router(config-if)#ip address 192.168.2.165 255.255.255.0

Router(config-router)#network 192.168.2.0
------------------------

Now change the IP address of PC-2 to 192.168.2.2

This should enable you to ping the ethernet interface of Router-2 as well as PC-2.



Report •


Ask Question