Can't use internet in any browser e

Peter February 5, 2009 at 19:37:42
Specs: Windows Vista Home Premium 64-bit
I am primarily a Firefox user - about 3 days ago, I noticed pages weren't loading in Firefox. I initially thought something was wrong with my connection, so restarted my cable modem and wireless router, but to no effect. Tried a different computer, and all pages loaded fine.

Never thought it was a browser problem, but tonight I just decided to try IE, and saw that pages loaded fine in IE.

I restarted my computer. Firefox still didn't work.

I uninstalled Firefox, deleted its directory on disk, then reinstalled. Still didn't work.

I tried installing Google Chrome, Opera, and Apple Safari. None of these worked.

I can also ping websites just fine.

I then installed AdAware, did a scan, and got no meaningful results.

I ran a Norton scan as well, no results.

So in a nutshell:

-Internet Explorer is working fine.
-Can sign into and use Yahoo messenger and Oovoo.
-Firefox, Google Chrome, Opera, Apple Safari are not working (i.e. getting "failed to connect" and "page load errors").
-No viruses or spyware found by Norton Antivirus or AdAware.
-Reinstallation and restarting were no help.

Anyone have any ideas as to what the problem here could be and/or how to fix it?

See More: Cant use internet in any browser e

Report •

February 5, 2009 at 20:59:35
Have you checked the Norton Firewall (if you have it installed) or any other software firewall you have installed to see if it's blocking access for those other browsers?

If have Norton and you have the installer for Norton and your product key handy, try uninstalling Norton and see if that fixes it. If it does, you can try installing Norton again and see if you get the same problem.

Assume that I already did an Internet search.

Report •
Related Solutions

Ask Question