can't connect to ssh server

February 17, 2009 at 19:26:32
Specs: Microsoft Windows XP Professional SP3, all updates, 1.989 GHz / 894 MB
i'm trying to set up an SSH server with tcp tunneling on my home computer, and connect to it from other computers on the internet. every time i try to connect (using putty as the client), i get a "connection refused" error.
i've tried using openssh and freesshd as the servers with the same results. i have the windows firewall set up to open the port i'm using. i've tried 12264, 22, and 443. i also have my westell 327w router set up to forward those ports, and set up with NAT to forward all unsolicited traffic to the server. no matter what settings i change, it never works.
i've tried port scanning my computer a few times, and sometimes it will show the ports as being open, and other times it will show them as being closed. if i run putty on the computer with the ssh server, using the local ip address (192.168.1.46), it connects fine and tunnels without a problem.
i'm thinking that something is blocking the ssh server from accepting remote connections, but i can't figure it out. the server is using the windows xp firewall, and is connected to the internet via wifi on a westell 327w router connected in bridge mode to a motorola surfboard SB5120 connected to comcast cable.

See More: cant connect to ssh server

Report •


#1
February 18, 2009 at 07:40:59
Are you using your external IP address from the remote client?

Report •

#2
February 18, 2009 at 11:00:18
yes. i'm using my external IP address, which i verified via my router and a few IP address pages (such as ip-adress.com)

Report •

#3
February 18, 2009 at 12:20:58
Where are you when you are attempting a remote connection, a friend's house?


Report •

Related Solutions

#4
February 18, 2009 at 12:53:11
i've tried a friend's house, school, and my house, all just say connection refused.

Report •

#5
February 18, 2009 at 13:14:28
Connect the machine running SSH directly to the modem, go to a friends house and try it.

Report •

#6
February 18, 2009 at 18:41:36
i can't try that. the computer running the server is too far away from the modem to connect to it without using my wifi router. now that i think about it, i had this same problem a long time ago while trying to set up a VNC server for fun. i eventually just gave up on it. do you think it would help to borrow and try a different wifi router?

Report •

#7
February 18, 2009 at 19:01:06
How far is the modem from the machine?

Report •

#8
February 18, 2009 at 19:38:34
in terms of running a cable, it would be somewhere around 100 feet. in terms of wifi signals, about 20 feet. the computer is on the second floor of my house, on the opposite side of the house from the stairs (the only way to run a cable). and the modem is also on the side of the house opposite from the stairs. i could buy a really long ethernet cable, but running a cable all through my house wouldn't go too well with my family.

Report •

#9
February 18, 2009 at 19:45:22
Run it down the stairs for an hour, just as a test. If it works, drop it out the window and run it around the house. Tuck it along the trim. No one will ever see it. I just did it for a customer who's signal was weak.

Report •

#10
February 20, 2009 at 19:18:45
i talked to my mom (who owns the modem and router) and she won't allow me to try to connect my computer directly to it, so i'm just going to give up on using ssh and try to write a program and set up a proxy server that routes the data through email programs. thank you for your help.

Report •

#11
February 21, 2009 at 05:54:41
Try it when she isn't home.

Report •

#12
February 21, 2009 at 05:58:40
Ok to start with the biggest question I have is, what are you using for an ssh server?

I have my OpenBSD box setup as my main firewall/router which is running behind my SOHO router. All traffic passes through the SOHO first, then the UNIX box. I had to port foreward port 22 (ssh) to the internal IP address of my UNIX box. I have no problems connecting so I have to suspect you've messed up your port forward or the ssh server software is not configured correctly.

The fact that you're getting "connection refused" leads me to think the problem is your ssh server.


Report •

#13
February 21, 2009 at 06:01:47
He said it connected fine on the LAN.

Report •

#14
February 21, 2009 at 06:10:03
I must have missed that while reading through this string.

Then it can only be he's misconfigured the port forward.


Report •


Ask Question