Articles

Can not map network drive on Belkin N+

July 30, 2009 at 01:35:38
Specs: Windows XP

Hi,
I am having a serious problem mapping a WD 1TB drive to my Belkin N+ router. The WD can been seen however when I try to map it I get the error 67 and the drive can not be mapped. Belkin just states that the problem is on my computer but I have like 8 computers in the network all sufferring from the same problem. Would surprise me if all the computers are the problem, so it looks like the router to me but Belkin is turning me down. Anybody any thoughts on this?

See More: Can not map network drive on Belkin N+

Report •


#1
July 30, 2009 at 04:55:15

A drive is mapped from one machine to another, through the router. What do you mean when you say that you are mapping it to the router?

If you can't map a drive from one PC to another, check your firewalls & share settings.

How do you know when a politician is lying? His mouth is moving.


Report •

#2
July 30, 2009 at 09:43:26

you can't map a drive until what you are mapping to is shared.

is this hd attached to the router? If so it needs to be configured for sharing.


Report •

#3
July 30, 2009 at 10:19:14

The HDD is hooked in USB poort of the Belkin N+. To share it I need to see it, don't I???? (I am not to sure sorry).
If so how do I share it in this case?
Thanks for the help

Report •

Related Solutions

#4
July 30, 2009 at 10:23:35

Hi Guapo,
Sorry for the confusion. What I mean is when I hook the HDD via the USB poort to the Belkin N+ there is a way to see the drive. However I would like to assign a letter to that drive so I can use it in the explorer. I believe this is called mapping, but as I am from The Netherlands I need to make a best guess.
This assigning does not work and therefor I can not use the drive from the explorer. Gone is my fun of the drive.
Firewall and anti virus is off thanks for the help

Report •

#5
July 30, 2009 at 16:12:22

I understand your setup now but I have no experience connecting a HD directly to a router. It never even crossed my mind.

Why don't you put it in the USB port of one of the PCs. Windows will give it a drive letter & you can map it.

How do you know when a politician is lying? His mouth is moving.


Report •

#6
July 30, 2009 at 16:59:40

StockTipper it REALLY helps to read the manual that came with the router.

You will find it says to open up the web interface of the router and then look for the drive connection page to configure the drive as accessable.

And no, you have to configure sharing before you can see it from your pc. Since it is connected to the router that is the place to configure it. After that you should be able to browse to the drive [it will have a name like you give it in the belkin config page]. Once you can browse to it you can map a drive to it.


Report •

#7
August 5, 2009 at 08:04:18

Oke Wanderer,
There is just an install disk to the router and NO manual or PDF.
In the index page of the router there is NO link or what so ever that might lead to setting somethings in the router.
Which version doe you have?
I have the F5D8235-V1.
Belkin gave me an upgrade of the frimware but that did not solve the problem.

Report •

#8
August 5, 2009 at 08:06:25

Guapo,
I'll need one PC always running to hook the disk to a PC.
That is why the F5D8235 comes with a USB poort.
Yet I have a small problem mapping and seeing the drive.

Report •

#9
August 5, 2009 at 08:44:19

Might want to review your manual here

http://cache-www.belkin.com/support...

Look at section 4 page 20 concerning the storage manager


Report •

#10
August 5, 2009 at 14:10:33

Hi wonderer,
Thanks for the help but I still have some questions (might be the language thing).
The manual says \\192.168.2.1\DeviceName
where “DeviceName” is the name that was assigned to the storage device.
Where do I assign a name to the HDD? I can reach the thing.
Second you say "open up the web interface of the router and then look for the drive connection page to configure the drive as accessable". I don't show a page about the drive where I can change anything?

You also say"And no, you have to configure sharing before you can see it from your pc. Since it is connected to the router that is the place to configure it. After that you should be able to browse to the drive [it will have a name like you give it in the belkin config page]. Once you can browse to it you can map a drive to it." As long as I can not reach it I can't configure it to share....
I also see that your manual is version V4. I hold Version V1.
Might that be an issue for the differences?
Appriciate the help given.

I now connected an other HDD.
It showed in the beginning and is gone now?????
Second when it showed and I wanted to reach it via My Network I got an error that I was not authorized???? and Invalid computer name
I do have administrator rights.
any thoughts about that?


Report •

#11
August 5, 2009 at 15:57:24

From your questions I can only assume you have not read the manual at the link I gave you nor did you review page 20.

I will post it here for your convenience

Storage Manager
The Storage Manager is an application that provides easy access to your USB storage device. Once this is installed, your storage device will appear as a drive letter (e.g., D:\) in your “My Computer” folder. You may read and write to this drive as if it were directly attached to your computer. Note that the Router currently supports FAT, FAT32, and NTFS file systems.

What I posted before was general how to based on working with a number of different devices which all accomplish the same thing but go about it differently.

Question now is did you catch that you have to install software to see the drive?
Did you also catch that you won't be mapping a drive?

HTH and have a nice day.


Report •

#12
August 5, 2009 at 23:48:12

Hi Wanderer,
I did read the part. I also copied part of the manual back into the message, but the part where your manual is reffering to is not in my router.
I can install the software (storage manager), which I did, but in the My Computer folder it does not show any HDD or additional letter. So it looks like the software does not work or recognise the fact there is a HDD attached to the router (yet the blue light on the USB port is on so there is a connection between the router and the HDD i guess).
THAT is the first and main problem I think.
Normally the storage manager should enable the HDD to show up in My computer but it doesn't.
Therefor I took the second option of the manual that explains how to do this manual. That is part of what I wrote above but than I need to know how to give the device a name (see earlier message).
When I try to reach for the HDD via \\192.168.2.1\ I get the message computer name unknown and that I am not authorized to acces the network?????
Strange on this is that sometimes the drive does and sometimes it doesn't show up on Microsft Network.
Thanks again for helping this dummy on this issue and when you write read this and that I sure do so!!

Report •

#13
August 6, 2009 at 07:54:11

Did you see the list of unsupported drives? Is yours on that list?

Can you access the web interface at 192.168.2.1?

When the drive is plugged in is the usb lite flashing blue, flashing amber or solid blue?

You ONLY access the drive via My Computer never Network Neighborhood.

If you have followed the instructions without diviation then it is time to contact Belkin techsupport or do a RMA on that router.


Report •

#14
August 6, 2009 at 12:23:17

Hi,
I have three different HDD'. Only one is on that list so the other two should work.
I sure can access the mentioned web interface.
My dive plugged in I see a solid blue light.
My computer does not show any additional drive unfortunatelly.

I take it that RMA means factory restore. done that after Belkin gave me the upgrade, but that did not help a bit.
Thanks for trying to help me as I tried to get support from the Dutch Belkin (they see the serial and don't support it in the USA) b ut they do not respond the last 3 days.....
Thanks again.


Report •

#15
August 7, 2009 at 08:09:56

rma is for return merchanize authorization. It is where Belkin support can't help you and it comes down to defective equipment.

Is there a newer version of the software you can download?


Report •

#16
August 8, 2009 at 14:18:40

Hi,
I have the latest Firmware.
They however claim it is in my computer. All of them????
I think it is some thing like a security issue but I can acces an other part of the network hat is mapped as well.
Any experience with a not accessable part of the network?

Report •

#17
August 24, 2009 at 19:40:19

I found this link while trying to get my new 1.5TB drive hooked up to my router, and accessible to my PC. I had problems similar to below, but all is working ok now.

I have a Belkin n-router with a USB port for plugging in a USB drive. I did this:
1. Plugged USB drive into router (belkin router now shows USB connected.
2. Installed Belkin storage manager on my PC, and tried to find the USB drive.
3. Searched through the router admin tool to try and find anything related to the USB drive (nothing there).
There was no drive automatically mapped as the documentation seemed to indicate, and when I tried to access \\192.168.2.1\, I got a listing for 'Expansion Drive', but was not able to access it. (general permissions or drive not working error message).
So, I
1. Temporarily plugged the USB drive directly into my PC.
2. Did some quick testing (make folder), then right clicked to rename the drive (to mydrive1 instead of 'Expansion Drive')
3. Took the USB off my PC and plugged it back into the router.
4. now, if I specify 192.168.2.1 in the file explorer, mydrive1 shows up, and I can see files on this drive normally.
5. Just for kicks, I right clicked on mydrive1 and mapped it to 'O'. It mapped fine, and I can see this 'O' drive from file explorer.

Hopefully this helps, I was a little frustrated looking at the 'did you read the instructions' comments that were not addressing the drive mapping question at all.


Report •

#18
September 10, 2009 at 11:30:21

I was having the same problem. What I did after reading all these posts was connect the drive to one of the network computers and right click on it and open the share option. Click on share this drive on Network. Unplug the drive and reconnect it to the router USB port and it should be able to open.
Hope this helps you.

Report •

#19
October 9, 2009 at 01:57:47

Hi,
I had a similar problem linking a 1Tb drive to my Belkin router.
A USB stick worked fine, but not the hard drive.
I could see the drive attached to the router with both methods, by storage manager and the ip address, but could not access the drive to read data (permissions problem)
I solved the problem by disconnecting the drive from the router, connecting directly to my laptop and re-naming the drive with a shorter name 10 chars and no spaces. Once reconnected to the hub it worked just fine. There must some restriction on the drive name, be it length or the use of specific characters. As my drive is now working, I don't really want to start experimenting with different names to find the limitations. Hopefully this may help someone with a similar problem.

Report •

#20
October 13, 2009 at 18:12:23

Thank goodness others have the same problem I have. The stupid permissions not working thing is causing me grief. I called support and after a great deal of me insisting they fix the problem (i.e. support was blaming file permission on the drive), he found someone that told him there is a problem with large drives, but they do not know how large the problem starts. Mine is a 1.5 TB. Now I wonder if something got lost in translation and it is to large of a Drive Name, not storage space.

One thing to note: If I mess around with rebooting the thing a lot I can get my drive working on the Belkin, but it always fails when I start copying large amounts of data over the network. I will try the small drive name and try to copy large amounts of data again an I will report my findings.


P.S. Mine is a Segate with the name "Expansion Drive." I think I will rename it to V or Vault.


Report •

#21
October 14, 2009 at 12:26:56

No Luck yet. I renamed the volume to Vault and I still cannot use the device. My problem started when I loaded about 100 GB on the drive. I am guessing if I remove the files from it will start working. I think that the Belkin device will have a hard time using large drives, but I have not given up. I'll continue to test and let everyone know what I find.

Report •


Ask Question