Articles

Solved .DMG without OS X using a PC

October 19, 2004 at 06:34:16
Specs: WInXP, Athlon 2500 Barton

Ok. I have spent over a week trying to work this one out, and EUREKA! I've FOUND IT!

So many have said it cannot be done. but it CAN.

Ok. Here's how to open a .DMG file on a pc to access the files.

First, download DMG2ISO

http://vu1tur.eu.org/tools/download.pl?dmg2iso.exe

The run the file DMG2ISO shell, and select yoru .dmg file. Then name your output file and convert.

Then.... download daemon tools

http://www.daemon-tools.cc/dtcc/portal/download.php?mode=Download&id=34

install it, and in the bottom right corner (running tasks) left click on it's icon, and select drive 0, and then find yoru NEW converted image (it will now be a .iso image since you converted it from .dmg to .iso).

NOW, you should see when you click 'my computer' a cd/dvd drive with the name of the file, like there was a cd/dvd in your machine (of course it is a virtual drive).

Now.... download Macdrive.

http://www.mediafour.com/products/macdrive6/

After installing Macdrive, you will be able to select VIEW MAC DISKS IN MY COMPUTER! And of course you have a virtual disc in your pc, which you get full access to!

Now just view all the files, and copy, and paste them to a new regular windows folder, or burn them straight to a cd/dvd and you're good to go! (I think you'll have to burn them straight to a dvd or cd in order for a mac to read them, but mac drive has this 'mac cd dvd' facility too!

:-). I had to spread this news as it took hours and hours of research to get this far, and I feel it is beneficial to the computing community.

:-)


See More: .DMG without OS X using a PC

Report •


#1
November 2, 2004 at 18:08:58

Hey,

I've downloaded dmg2iso.exe and dmg2iso.pl. I ran the .exe and the command promt quickly appears and disappears. I was not able to type anything or do anything with the .exe. Is the program still running? What happened to it? How is it suppose to be run and able to convert dmg to iso? Thanks.

Tony



Report •

#2
November 17, 2004 at 06:18:02

Tony

I'm having the same problem!

Did you find a solution?

Nash


Report •

#3
November 20, 2004 at 10:54:23
✔ Best Answer

You need to open up the windows command prompt to get the file to work. It's command line only, but very simple.
Usage:
C:\stored_files_directory\dmg2iso.exe myfile.dmg myfile.iso

So in other words, navigate to where your files are stored and type in 'dmg2iso.exe', as long as it's in the same directory as your .dmg file, then type in the name of the .dmg, in ths case, myfile.dmg and the name of the iso that you want created; myfile.iso.

Pretty simple. =P
Hope this helps, if not, my web site's below, ask me there.



Report •

Related Solutions

#4
November 26, 2004 at 05:33:38

Heartiest Thanks to everyone who has posted solutions on this page. It is quite useful.

I have a .SIT archive on my Windows XP Pro based PC. That archive i had downloaded from the internet. The file is actually 488 MB total and 486 MB got downloaded. Now the problem is that although a large part of the file (just 2MB short) is downloaded Stuffit is not ready to simply extract the file from incomplete archive.

I surfed more than 200 sites for this purpose. And no program on thr net can actually atleast extract some part of the file.

Does someone have an answer to extracting incomplete .Sit archives ?


Report •

#5
December 6, 2005 at 20:42:54

I keep getting...

Syntax: dmg2iso <filename.dmg> <filename.iso>

Beforehand I have this typed...

"C:\Program Files\BitComet\Downloads\Star Trek Elite Force II\dmg2iso.exe" Elite Force II CD1.dmg Star Trek Elite Force II CD1.iso

Whats the problem here? Does the ISO have to contain the same name as the original file in order to convert, then change the name afterwards when its finished?


Report •

#6
January 3, 2006 at 15:59:55

Fleet - You need quotes around any filename that has a space in it. That's universal to the command line, because otherwise it interprets a space as a break to the next arguement.

Here's the replacement:
"C:\Program Files\BitComet\Downloads\Star Trek Elite Force II\dmg2iso.exe" "Elite Force II CD1.dmg" "Star Trek Elite Force II CD1.iso"


Report •

#7
January 6, 2006 at 10:25:57

Hi, I tried doing the same with a dmg file on my pc. (in the right folder I typed: "dmg2iso.exe" "MachineWash.dmg" "MachineWash.iso")But when I hit ENTER, I'm getting an error saying something like (sorry, I'm using an italian pc): Prompt of commands "dmg2iso.exe" "MachineWash.dmg" "MachineWash.iso" The CPU NTVDM has encountered a non valid instruction. CS:0f69 IP:023e OP:db b 7 6e 1 a 29 Choose close to terminate application.

What am I doing wrong?

Martijn


Report •


Ask Question