Articles

Adobe Flash Player won't install

November 25, 2012 at 18:13:13
Specs: Mac OS X version 10.5.8

I have an iBook G4 Mac OS X version 10.5.8 and I'm trying to install Adobe Flash Player. But, it won't install onto my computer.

I'm sorry it's not a lot of details.


See More: Adobe Flash Player wont install

Report •


#1
November 26, 2012 at 01:52:04

You need an older version of the Flash Player. New versions of Flash won't install on the iBook range because of the incompatible PowerPC processor inside them.

New versions of Flash require an Intel processor as fitted to all new Macintosh computers.

You can get older versions of Flash Player here, but I can't tell you which is the last iBook-compatible version: http://www.oldversion.com/macintosh...

try Version 2 (the oldest version for Macs, bottom of list).


Report •

#2
November 26, 2012 at 10:02:47

When I did that, I tried opening the file to install it. This is what popped up:
MZê

Okay, there's a lot more, but this is all that's showing up on here.

At the top, though, it does say:
This program cannot be run in DOS mode.


Report •

#3
November 30, 2012 at 01:18:18

You Mac version is too old, you'd upgrade your Mac than find a old version Adobe Flash Player

Report •

Related Solutions


Ask Question