Articles

Running a .run file from command li

August 11, 2005 at 22:26:39
Specs: Suse 9.3, P4

How do I execute a .run file directly from the internet. Specifically http://www2.ati.com/drivers/linux/ati-driver-installer-8.14.13.run

Be gentle as I'm very new to Linux. What do I type from console, I kind of understand the .Sh and .RUN but just can you tell me the entire command I need :)


See More: Running a .run file from command li

Report •


#1
August 12, 2005 at 17:55:42

You can run any executable by typing its name on the command line, but only if it's location is in your PATH variable. PATH usually contains /bin, /usr/bin, and other locations, but for security reasons it should never contain the current working directory.

One way to execute something that isn't in PATH is to specify its full path, but Linux and UNIX provide shortcuts. Every directory contains "." and ".." directories. ".." is the parent directory, so "cd /usr/bin/../" takes you to /usr, for example. The "." is the directory itself, which doesn't seem particularly useful. In your case, however, knowing what the "." is helps a great deal because you can specify the path to your working directory with "./".

If you're in the same directory as the "ati-driver-installer-8.14.13.run" file, you can run it with "./ati-driver-installer-8.14.13.run", but please continue reading.

If you get a "bash: ./ati-driver-installer-8.14.13.run: Permission denied" error, you need to make the file executable. "chmod +x ati-driver-installer-8.14.13.run" will accomplish this. When you get some free time, read about Linux or UNIX commands and file permissions. The basics will be the same for any UNIX-like OS.

Since you're trying to install drivers, you'll want to be root, the Linux/UNIX "Administrator" equivalent. UNIX-like OSs have a nifty command called "su" that will ask you for your root password. If you get the password right, your prompt should change to remind you that anything you run from that shell will run as root. If you aren't sure who you're running as, check with "whoami". It's usually a good idea to not run as root, then use su when you need to run something as root. You'll be less able to break things, and malicious code (not that you're likely to encounter any) will do less damage.

Finally, if Suse has a way of adding the ATI drivers with YaST, do that instead. It's usually better to let your distibution manage as much as possible. Upgrades are easier and you don't end up with multiple copies or incompatible versions of packages.


Report •

#2
August 14, 2005 at 15:41:52

I figured how to download it with konqueror browser. Firefox crashed (prolly cuz I didn't update it) I just went to console and typed sh asdfsadf.run and it worked. Stupid ati radeon 9550 doesn't have 3d acceleration support which SUCKS. I even tried Suse's alternative method successfuly and found out they just dont support 3d ... oh well...

Appreciate it


Report •

#3
August 14, 2005 at 16:31:17

Why do you think 3D acceleration isn't supported? The ATI driver release notes specifically list the 9550 as supported.

The open source drivers probably don't support the 9550 yet unless you get the latest unstable version, but the ATI drivers should work.

Also, "sh asdfsadf.run" only works if asdfsadf.run is a shell script. "./asdfsadf.run" works on any executable binary.


Report •

Related Solutions

#4
August 16, 2005 at 22:31:38

Nope, I ran both of their installations properly and with help of a linux addict, and neither show 3d acceleration. True it shows up in drivers as the correct card, just no 3d accel which is garbage

Report •


Ask Question