XOSL From CD Issue

April 14, 2009 at 05:02:36
Specs: Windows XP
Hello all

Hopefully a simple problem here, I feel like I'm just too tired to see it. Sorry if I ramble..

Basic setup here; 1 CDROM, 1 HDD carved up for OSes
part1 = 5G NTFS
part2 = 32M FAT (for XOSL, my multiboot loader)
part3 = 5G NTFS
extended part = many more logicals, etc

I have a bootable DVD I made last year with XOSL on it, and installed the loader to the 32Meg chunk as a dedicated partition (I don't have DOS anymore).

This is the same setup I use on the computer I'm using right now, and for the life of me I can't remember what I did at the stage I'm at with this new one.

The problem is that after installing XOSL, it says to reboot. Fair enough, but my BIOS boot seqence still has the CDROM as #1 so it just boots back to my custom menu from which I won't get into the loaders GUI.

If I pull the DVD out before the reboot, or even if during that reboot I stop off at BIOS to switch the sequence to HDD as #1, I get hung up at "Verifying DMI pool data......".

I can't remember what I did last year with what sounds like a pretty common and inevitable problem with the boot sequence. I'm assuming the obvious; that I need to yank the DVD, just like someone would do with a floppy before rebooting, but then why the halt during the HDD boot?

I mean, if XOSL is installed properly (which it seems to be since the MBR shows 'unknown IPL' like it should), and the MBR is pointing at the second partition (I assume, since the 32M partition is flagged as bootable/active), why is it acting as if there's no loadable data by simply hanging on this DMI message?

It's my understanding that the odd BIOS might not handle boot sequences at all, and will stop after the first device fails no matter whatelse it's told to check next. I'm a little suspicious of this BIOS, for what that's worth (I could elaborate).

I've got several tools for partition data editing, and I'm not completely new to this, so please fire off some suggestings, I'm too tired to think anymore.

~ Cheers

See More: XOSL From CD Issue

Report •

April 14, 2009 at 13:00:08
Maybe not a cold boot. Power off system but remove the cd before you power it off.

I assume xosl is similar to grub. There should be some config and in most cased the OS's bootloader needs to be on the partition you want to load. Some require chain loading with other options.

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

April 14, 2009 at 13:50:27
I don't have much experience with boot loaders but I thought they should be on the first partition on the drive.

Report •

April 14, 2009 at 15:19:23
I did try xosl out with a hdd with no primary partitions and had its config files on the very last extended volume, it had no problems. Its config files are recommended to be on a dedicated partition but does not have to be.
The start sector of partition with the config files is embedded into MBR boot code.

Try items #3/4 at posted site.

Report •

Related Solutions

April 15, 2009 at 00:18:06
Update: My BIOS has no such option to reset any values, it would no doubt involve a jumper.

I'm convinced the loading sequence is getting to within 1 last step of success.

From hitting the 'restart' option within XOSL's setup (after what appears to be a simple clean install), the computer restarts - runs through POST (all the way, ending with the DMI pool) - searches for a CD (but I've removed it before rebooting) - failing that, then switches to HDD0 MBR and gets caught up either trying to figure out the new 'unknown IPL' that XOSL wrote there, or understands it and goes to load the FAT16 partition (part #2 with XOSL on it), at which point the problem is on that partition and it halts/hangs.

This is about as narrowed down as I can get. I never had the XOSL partition not just load up fine in the past. It's the very same DVD image I used a year ago.

I'm all but finished working on this computer, if I could just get this loader working. Argh!

Report •

April 15, 2009 at 02:53:48
Update: I've gotten one step closer and eliminated some possibilities in doing so.

In the course of repeated installs/restores/uninstalls of XOSL, back and forth into WinXP (that's what's on partition #1 btw) so I could format/delete/recreate the loaders partition, etc, the booting process has gone slightly further.

It now gets to where XOSL shows the text:
"Extended Operating System Loader 1.1.5"
but then hangs indefinitely.

Normally, that text would be no more then a flash before the GUI comes up. I'd like to think now it's merely a video render issue, but this feels more and more like corrupted file data, no? At some point it bulldozed in a little further.

I know tons of people use XOSL as their multiboot frontend, but search after search isn't showing anything like this glitchy annoying last step headache.

Please, suggestions?

Report •

April 15, 2009 at 09:33:55
During install try selecting a different "VIDEO MODE"

copied from xosl's help files
{It is only possible to install XOSL to a FAT16 or FAT32 drive. FAT12 is not supported. Note that small FAT16 drives (less than 32Mb?) are formatted as FAT12 automatically, hence you cannot install XOSL to such a drive.} may be your small partition is being formatted as fat12 ??

If you have any other FAT32 partition (extended volumes), try installing to that partition.

If you are getting "Extended Operating System Loader 1.1.5" displayed then the MBR boot strap code is finding its files on part #2.

You may have to use a different boot manager.

Report •

April 15, 2009 at 15:33:17
Semi-Solved: I now have the loader booting up and running properly, however not as I originally intended.

I tried many variations throughout this whole process. Video mode, mouse, extra add-on apps being installed with XOSL, etc. Today I tried a different physical position on the hardrive by creating several partitions ahead of the one for XOSL. Nothing worked, so I caved in and decided to use a DOS partition instead of my intended 'dedicated partition'.

To do that, I actually had to install Win98, since it's all I have as far as DOS goes. Infact, just installing Win98 was a pain because of all the newer hardware issues that came up.

Oh well. As much as I hate loose ends and not resolving a problem with a confirmed, solid fix, I'll take this one as a win and move on.

TopFarmer: I've read the included docs but must have missed that note about partitions < 32M being formatted as FAT12. Very interesting. I now have to wonder if simply bumping the partition size up alittle would have saved this whole problem from coming up. Even though my older system used a 32M partition and worked fine, you never know.

Anyway, I greatly appreciate the time you people took to read and reply. It's always a comfort to feel that kind of comradery when you're getting beat by something.


Report •

Ask Question