Windows Vista Stuck on Microsoft Corp Loading

November 3, 2011 at 20:46:07
Specs: Windows 7

My Sony Vaio which is running Windows Vista is getting stuck on the Microsoft Corporation loading screen. After a few minutes on the loading screen a black screen with blue edges flashes up for a split second before the computer restarts itself.

When restarting I come to a screen which says "windows error recovery - Windows failed to start."

I then have the choice to start windows normally which leads to the same result or go in to startup repair.

This takes a while to attempt it's repairs and then comes up with a box which tells me to click finish to restart my computer which will finish the repairs. if they were not succesfull it will run again which it does and starts the whole circle again.

Is there a fix for this?

I haven't installed any new devices for a long time that I am aware of however I did recently buy a replacement charger for my laptop which I plugged in with the sony connection attached incorrectly just before this problem arose.

Also worth noting is I have had a windows error box come up before my sign in screen for a while now but when I click enter it dissapears and everythign is as normal.

I have just attempted to click ctrl + alt + delete at the loading screen which has temporarily got me to my sign in screen which the laptop has now frozen on.

Any suggestions for a fix are welcome but please keep in mind I am not a technical whizz and may not be able to understand technical speak.

Many thanks,

See More: Windows Vista Stuck on Microsoft Corp Loading

Report •

November 4, 2011 at 18:25:35
download a copy of this:

create a bootable cd & boot from if. At the boot screen one of the options will be :
Run from the ram, choose this option. run it for 2 hrs and report back results. If all goes well, next may be to test the HD.


Report •

November 4, 2011 at 22:46:34
bad ram module(or poorly seated), failing hard drive or corrupted startup files.

Report •

Related Solutions

Ask Question