Why CMOS battery is not working on my computer?

Acer Acer aspire x1700 main board mother...
June 9, 2014 at 14:43:04
Specs: Windows 7
Hi, I removed the cmos battery and reseated. Now the battery seems not working as before because always I receive a message from bios stating to set date and time. I do, but when I unplug the computer from mains and then plug it requires to set the date and time again and again whenever it is unpluged. Please I need your help asap.
JD

See More: Why CMOS battery is not working on my computer?

Report •


#1
June 9, 2014 at 15:37:31
Sounds like you need a new battery. Did you try one?

Report •

#2
June 9, 2014 at 16:43:57
Presumably you did re-install/reseat if the correct way up - if a typical button style battery?

If so then as "grasshopper" (you still wandering around China and the olde west?) suggests - time for a new batter? They don't last forever...


Report •

#3
June 9, 2014 at 17:30:39
Just curious---why did you feel you needed to remove and re-seat it to begin with?

"Channeling the spirit of jboy..."

message edited by T-R-A


Report •

Related Solutions

#4
June 10, 2014 at 17:10:08
Hi,thanks for your reply! yes I tried a new battery but the problem persists.

Report •

#5
June 10, 2014 at 17:12:24
Hi, yes I replaced a new battery after nearly 5 years. but....

Report •

#6
June 10, 2014 at 17:21:48
Hi, I;ve done it to reset the bios to defaul state as my computer is bombing me with blue screans and freezes.
Any idea is welcome.
Thanks!

Report •


Ask Question