Weird echo, skipping sound on voices in videos and music.

August 16, 2012 at 11:39:25
Specs: Windows Vista
Hi, I am having problems with an echo sound, or skipping sound when I play videos at all or listen to music. Its like a long drawn out noise in between videos, and songs. What can I do to fix this?

See More: Weird echo, skipping sound on voices in videos and music.

Report •

September 3, 2012 at 04:27:45

Before I proceed with the troubleshooting steps, please let me know if you face this issue while watching videos online or offline?

1. Open Internet Explorer, click on “Tools”, click on “Delete Browser History” then click on “Advanced” and click “Reset”.

2. Ensure "Enable Hardware Acceleration" is unchecked, if not, right click on the video after opening video online (in hulu, youtube). Then click on the first folder “Display”. Uncheck "Enable Hardware Acceleration".

3. Update Media Player Classic by clicking on the below mentioned URL:

4. I will also suggest to update Flash Player from the site:

5. Install the latest version of Adobe Flash (necessary for streaming YouTube videos) after removing any old versions you've installed. In order to know the steps to upgrade to the most recent version of Adobe's Flash Player, click on the URL mentioned:

6.I would also suggest you to update the Sound drivers .

7. You can even refer to the which would help you in troubleshooting video issues in Windows Media Player.

Please feel free to contact for further clarifications.

Thanks & Regards
Debbie B

Report •
Related Solutions

Ask Question