WD Elements 1042 problem

May 12, 2013 at 07:41:20
Specs: Windows 7
Bought 2 seperate drives, computer reads both as the same so there is conflict. I re-assigned the drive letter to H this changed both of them, so still the same problem of conflict. Deleted H from the drive, now I cannot open either hard drive, in "my computer" even though it is recognised by "safe to remove" icon. Help11

See More: WD Elements 1042 problem

Report •

May 12, 2013 at 08:16:54
Did you do that in disk management? If not, reboot & open disk management. I was never a fan of WD. I had a few go bad.

How do you know when a politician is lying? His mouth is moving.

Report •

May 12, 2013 at 08:17:10
I don't understand it since I also have two identical WD Elements drives (though mine are both designated "HDD 1021" in "Safely Remove Hardware") and yet I have no conflict at all when I have them plugged in at the same time. Windows just gives them both a different drive letter and I have no problem at all.

If you bought them both at the same time (which I did not) you probably plugged them both in together to your PC for the first time as well. I suggest you unplug them both.
Now plug only one of them in and wait for Windows to recognise it, then check that you see it with a drive letter in Windows Explorer.

Then, and only then, plug the second one in and Windows should assign a different letter to it automatically.

Those two drive letters will then be remembered and assigned automatically by Windows for that specific drive each time you plug it in.

Report •

Related Solutions

Ask Question