Video Card Install Problem

August 23, 2011 at 13:02:44
Specs: Windows 7, pentium 3.3/3.3 Ram
Troubleshoot Radeon hd 6450 Install. No Display After Install. Reinstall Old Video Card All Is Fine. Tried Downloading Drivers First And That Didn't Work. Any Ideas?

See More: Video Card Install Problem

Report •

August 23, 2011 at 13:31:43
Tell us the make and model of your brand name system, or if you have a generic desktop system, the make and model, or at least the model, of your mboard.

"HD 6450"

System requirements

400 Watt or greater power supply recommended (500 Watt for AMD CrossFireX™ technology in dual mode)

The latter is for two HD 6450 video chipsets.

The card requires up to 100 watts - up to 8.3 amps at +12v - just for the card's video chipset.

What is the (max combined output) wattage capacity of your power supply ?
That's on it's label.

If it's less than 350 watts or so, your system may NOT boot properly, you may have NO video when the HD 6450 card is installed.

If you need a power supply with more capacity, usually you can use any standard sized standard ATX power supply.

Standard (PS/2) power supply size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

Don't buy an el-cheapo PS.
See response 3 in this:

I no longer recommend Cooler Master, AOpen, or Sparkle power supplies.

If you ARE always getting video from the HD 6450 while booting, but NO video after Windows loads, only AFTER you have installed the specific software for it in Windows, that's easy to fix.

You MUST follow the installation directions for the card .

DO NOT point Windows to where drivers are when Found New Hardware pops up for the card !

Report •
Related Solutions

Ask Question