VGA card has power, but no display i think problem @ vga

January 4, 2014 at 09:50:32
Specs: Windows 7, 2 GB ram(-)Core2quad Q8400 prosessor
hi.i need a help,,, I placed a new motherboard ASRock G41C-GS yesterday and connected everything correctly well. And started my pc and it had no problem on that moment.But i didn,t installed drivers CD(CD Rom drive has dead).even though i was able to use my VGA card without drivers CD(my VGA card is HIS.inc PCI Express-ATI radeon HD 4670) i played some internet games with maximum quality for few hours and shuted down the computer. Today i started my pc and changed wallpaper,then suddenly shutdowned, i restart pc again and there was no problem to play games.After; i shut downed the pc and started pc after few hours.But it started but no display (i saw vga fan and cpu fan are working).then I turned off it by plug and connected my monitor cable to motherboard's monitor port.It worked well and installed drivers with my friends CD ROM drive.but VGA card was not responsing when i connected monitor to VGA.......

please eeeeeeee what happened to my VGA card, dead?


See More: VGA card has power, but no display i think problem @ vga

Report •


#1
January 4, 2014 at 10:08:30
Check the BIOS settings for VGA settings.
Especially the prefered VGA.
It might be set to onboard VGA instead of PCI or PCIe card.

Report •

#2
January 5, 2014 at 07:00:24
I don't know much on bios. but i went to BIOS --> ADVANCED --->CHIPSET---->Video Graphics Adapter, ,,,;..@ video graphics adapter; PC had choosed PCI and I changed it to PCI Express. and saved and exit.automatically it restarted but there was no result(no display [but fan is spinning])
did i do it correctly or something more to do?? please help

message edited by Pasan


Report •

#3
January 5, 2014 at 09:41:02
Have you tried to reset the system BIOS to factory default settings.
The default settings normally work for that.

Another question is, when entering the system BIOS, did you get the screen output from the onboard graphics card or the PCIe graphics card?
Where is the monitor connected to?


Report •

Related Solutions

#4
January 6, 2014 at 08:08:58
to enter BIOS I connected monitor signal wire to asrocks mother board's monitor port.And also i can boot windows without any problem when i connected to monitor port @ motherboard

Report •

#5
January 6, 2014 at 09:31:20
Have you installed the driver for the ATI radeon HD 4670?
And if so, you should be able, to start the configuration program for the ATI graphics card, to configure it as the primary graphics card.

Report •


Ask Question