USB port not responding

May 8, 2009 at 23:55:42
Specs: Windows XP

My computer has recently decided not to allow me to access my usb stick on any of the usb ports. Everytime I put my USBstick into one of the ports a message pops up next to a small icon in the bottom right hand corner of the screen(next to the time) saying that I can now safetly remove the hardwear.
I have tried all 4 ports and all of them have the same message. However I am able to print anything from my computer......

if anyone knows how to fix this problem they really will be a lifesaver,


See More: USB port not responding

Report •

May 9, 2009 at 00:21:15
I have tried 3 different USB sticks, I have both re-installed and installed the drive I still get the same message....

Report •

May 9, 2009 at 08:39:34
So, you DON'T get a message that your flash drive has been identified?

Have you looked for the flash drive in Disk Management? If the formatting of the drive is trashed it may not show in My Computer.

What do you mean by this? "I have both re-installed and installed the drive I still get the same message"

Report •

May 9, 2009 at 09:20:37
I went into device management and tried to unistall and then re-install the drive but no succes.....

Report •

Related Solutions

May 9, 2009 at 15:29:06
I said DISK MANAGEMENT, not device manager.

Report •

May 10, 2009 at 00:38:35
I have looked in the disk management, however no drives are seen!

Report •

Ask Question